Manually setting GSM Band


#1

Hi all,

I’m wanting to manually set my device to use to a specific GSM band (in this case: mono-band mode 900 extended MHz) and I need to make sure that I’ve got this correct.

From reading the AT Commands Interface Guide for Firmware 7.44

I see that I can use +WFM to see currently enabled/disabled features.

AT+WFM=2

+WFM: "MONO900",0,0
+WFM: "MONO1800",0,0
+WFM: "MONO1900",0,0
+WFM: "BI9001800",0,0
+WFM: "BI9001900",0,0
+WFM: "MONO850",0,0
+WFM: "BI8501900",0,0
+WFM: "QUADBAND",1,0
+WFM: "EFR",1,0
+WFM: "HR",1,0
+WFM: "DTXDATA",1,0
+WFM: "DATA144",1,0
+WFM: "SIM3VONLY",0,0
+WFM: "SIM1V8ONLY",0,0
+WFM: "SIM1V8AND3V",1,0
+WFM: "SIMREMOVE",1,0
+WFM: "OFFWHENUNPLUG",0,0
+WFM: "SWITCHATT",1,0
+WFM: "CPHS",1,0
+WFM: "SIMSPEEDENH",1,0
+WFM: "LOCA",0,0
+WFM: "AMR",1,0
+WFM: "NT_6K",1,0

OK

From this I can see that QUADBAND is currently enabled and I take it from the docs that only one band can be enabled at one time.
The Docs also mention that I need to use +WMBS for band selection.
The blurb for +WMBS says: This command is allowed only if the selected bands are supported (please refer to +WFM command).
Which from my understanding MONO900 is available just disabled?

So I check the current settings:

AT+WMBS?
+WMBS: 5,0

aka Dual-band mode 900E / 1800 MHz

Check the available settings:

AT+WMBS=?
+WMBS: (0,1,2,3,4,5,6,7),(0-1)

Showing that mode 1 (mono-band 900E MHz) is available

And to change it:

AT+WMBS=1,0
OK

AT+WMBS?
+WMBS: 1,1
OK

AT+CFUN=1       // Needs to restart to take effect

AT+WMBS?
+WMBS: 1,1

So at this stage I think that I’ve set it up, but checking +WFM

AT+WFM=2
+WFM: "MONO900",0,0             <------ Was expecting a 1,0 here
+WFM: "MONO1800",0,0
+WFM: "MONO1900",0,0
+WFM: "BI9001800",0,0
+WFM: "BI9001900",0,0
+WFM: "MONO850",0,0
+WFM: "BI8501900",0,0
+WFM: "QUADBAND",1,0            <------ Still enabled
+WFM: "EFR",1,0
+WFM: "HR",1,0
+WFM: "DTXDATA",1,0
+WFM: "DATA144",1,0
+WFM: "SIM3VONLY",0,0
+WFM: "SIM1V8ONLY",0,0
+WFM: "SIM1V8AND3V",1,0
+WFM: "SIMREMOVE",1,0
+WFM: "OFFWHENUNPLUG",0,0
+WFM: "SWITCHATT",1,0
+WFM: "CPHS",1,0
+WFM: "SIMSPEEDENH",1,0
+WFM: "LOCA",0,0
+WFM: "AMR",1,0
+WFM: "NT_6K",1,0

Have I actually set the device to use the specified band? Or is there something further that I need to do?
How can I test that it’s using the specified Band?

Any suggestions or help would be most appreciated.


#2

Hi,

at+wmbs is the command for setting and checking which band you are on. You only need this.

at+wfm is only for querying the available features of that modem (what you can do with it), not the currently active mode.

best regards,
Gregor Bader


#3

Superb, thank you for clarifying that Gregor :slight_smile: