Band change


#1

Hi!

     I'm trying to change the operation band on my modem and got the following terminal output:

AT+WMBS?
+WMBS: 5,0

OK

AT&W
OK

AT+CFUN=1
OK

+WIND: 13

+WIND: 1

AT+WFM=2
+WFM: “MONO900”,0,0
+WFM: “MONO1800”,0,0
+WFM: “MONO1900”,0,0
+WFM: “BI9001800”,0,0
+WFM: “BI9001900”,0,0
+WFM: “MONO850”,0,0
+WFM: “BI8501900”,0,0
+WFM: “QUADBAND”,1,0
+WFM: “EFR”,1,0
+WFM: “HR”,1,0
+WFM: “DTXDATA”,1,0
+WFM: “DATA144”,1,0
+WFM: “SIM3VONLY”,0,0
+WFM: “SIM1V8ONLY”,0,0
+WFM: “SIM1V8AND3V”,1,0
+WFM: “SIMREMOVE”,1,0
+WFM: “OFFWHENUNPLUG”,0,0
+WFM: “SWITCHATT”,1,0
+WFM: “CPHS”,1,0
+WFM: “SIMSPEEDENH”,1,0
+WFM: “LOCA”,0,0
+WFM: “AMR”,1,0
+WFM: “NT_6K”,1,0

      Even though I tried at+wmbs=5 and at+cfun, modem seems to be in quadband. Do anyone know why it happens? 

       Thank you!

#2

Hi,

+WFM show you the features supported, with QUALBAND enabled mean your modem support all the bands.

+WMBS is the only command used to change band.
You used AT+WMBS=5,0 so that the modem should work in dualmode(900E/1800), you can check using AT+WMBS? anytime and whatever it show, it’s the current working band, no if/but.

I think you can prove this by setting a band that not servicing in your area, e.g. “AT+WMBS=0,1” (or other mono band), and if no registration possible, it proves it working

L


#3

To go to quad band, you have to run AT+WMBS=7,1
Please note, you have to run 7.44 or higher version of firmware.

Rudolf


#4

Thank you for your answers! It’s all clear about the commands.

Indeed, my problem is that, as soon as it’s registered, modem tries to start the bearer, reach a timeout and got reset(I suppose this is because of the watchdog in idle state). Lets hope other posts help me solve it.