M2M Studio doesn't support multi-user PC?


#1

Windows XP + SP3

In line with all the best practices, I only use the Administrator account when absolutely necessary; eg installing software.

Having installed M2M studio, back at my “normal” user account, it still defaults to looking in the Administrator’s folders for the default workspace.

Also, an icon was createted on the Administrator’s desktop, but not on my desktop.

It seems that M2M studio doesn’t properly support multiple users on a single PC - is that right?


#2

Hiya,

Log in as administrator, open Windows Explorer, navigate to Documents and Settings -> All Users -> Desktop and drag the M2M Studio icon there. This will make the icon appear on all users desktops. Not ideal, but a workaround.

If you edit

\configuration\.settings\org.eclipse.ui.ide.prefs

(under your M2M Studio installation folder), you can change the list of recent workspaces to point to wherever you want. You can also re-show the workspace selection dialog at start-up if you have checked the Use this as default and do not ask again check box at startup.

This is probably a fault in the Eclipse installer than a strictly M2M studio issue.

BTW, you shouldn’t need to be administrator to install M2M Studio. Eclipse (basis of M2M studio) can be installed by anybody - into any directory that the user has write/modify access to. The Eclipse install has been specifically designed so that is doesn’t require write access to either the registry or other system directories. You can (and I do) have multiple copies (different versions) installed side by side without interference - as long as you don’t install them in the same directory!.

Of course, somebody is about to prove me wrong…

You shouldn’t have to do this though - these little niggles should be reported to the upstream devs…

ciao, Dave