M1306B communication problem

I have a M1306B, on power-up it has a solid red light with no changes. When I connect to it via serial (Windows 2000/Hyper-terminal) it gives no response. When I change the SIM card I get no changes in the led status light.

The power adapter was purchased from a distributor along with the serial cable as official fastrack parts.

Has anyone any ideas on why I am not seeing activity on the LED or why I am not getting any response via serial? Thanks.


Managed to get it working via baud rate 9600. Any reason why I can’t use 115200 like the manual sayas?

It is working perfectly fine for me at 115200 bps. there seems to be no reason why it should not work with 115200 bps. what is the procedure you adopted to use 115200?? Do you use TMT or Hyperterminal ??

Check your System settings for modem and COM settings (speed limits, because 9600 is default).

What did you try?

Have you tried setting it to 115200?

Have you tried setting it to autobaud?


Even i had the same problem regarding this one.

As far i knw is that it s due to GSM modem which fails to register itself into the network.

No, that would have nothing whatsoever to do with the ability (or otherwise) to select 115200 baud!

No my modem working fine with that baud rate(115200 bps), sometimes that red light indicator will stop blinking and also the Hyper terminal will also stop responding.

If the red light stops blinking, the modem has lost GSM registration - you should be able to see this by enabling +CREG and/or +WIND unsolicited notifications.

But losing GSM registration should not stop it communicating via its serial port.

If the red light stops blinking, and the modem stops communicating via its serial port, then the modem has crashed.

Do you have an Open-AT application running in your M1306B?

This behavior also happens in my case.
I have an Open-AT application running on M1306B.
In detail, if the modem does not have gprs coverage for a time of several days, it crashes and is necessary restore the power in order to restart the application.

Could someone give me a clue about this problem?
Thank a lot

Same problem, no network registration.

This sloved the problem: