LX60 lua ssl.https: error loading module from ssl.core

Lua code that works on the RV55 does not work on the LX60. Firmware version of the LX60 is 4.14, but 4.13 on RVs.

Line causing error:

local https = require ‘ssl.https’

Error Message:

In thread: 0x1d29060: error loading module ‘ssl.core’ from file ‘/root/aleos/usr/readyagent/lua/ssl.so’:
/root/aleos/usr/readyagent/lua/ssl.so: undefined symbol: SSLv3_method stack traceback:
[C]: ?
[C]: in function ‘require’
/root/aleos/usr/readyagent/lua/ssl.lua:7: in main chunk
[C]: in function ‘require’
/root/aleos/usr/readyagent/lua/ssl/https.lua:10: in main chunk
[C]: in function ‘require’
main.lua:568: in function ‘post_data’

Thank you for any ideas!

Hi mfp,

Please try it on RV55 firmware version 4.14.
Does it work fine on RV55 firmware version 4.14?

Is there an archive for v4.14? I found 4.15, and the RV50 worked fine. (Sorry, it’s a 50, not 55) . I could update the LX60 to try 4.15…

You can try it with version 4.15

Sorry, I forgot to update this. I tried fw 4.15 on the LX, and the code now works. Strange about 4.14. Thanks!