Lost communication with the FXT009

The FXT09 is not communicating through USB anymore after an attempt to download Firmware, using Development studio 2.1.1. I cancelled the download while it was still downloading. I do not know if this is what created the problem.
Now the FXT09 front LED turn on RED on power-up and stays off. Before it was flashing on and off when everything was working prior to the download attempt.

I am using the USB driver
When attempting to open the USB port to communicate using the Target Manager of developer studio here is the errors:

Open and load port COM1 => ERROR: Time out: 10000ms
Open and load physical port COM1 => ERROR: Time out: 10000ms
Open port COM1 => ERROR: Time out: 10000ms

The TMC console does not respond to any AT command.

How to I get the FXT09 back to the factory default which I know was working fine?
Is the FXT09 dead since the front RED LED does not flash or stay on?
Did I flush the firmware and therefore there is nothing running on the FXT09?
Is the serial communication a fallback port that I should try since the USB port since not to be working?

Any suggestions would be appreciated.

Thanks a Bunch.

The documentation says this about the led:

LED is ON for 100ms, OFF for 200ns:


Are you trying to connect to the right port ‘USB(COM)’ ?
If the connection is stuck at ‘Load model element: Target Informations’ you should read [url]https://forum.sierrawireless.com/t/usb-driver-v3-822-hangs-downloads/5417/1]

Reset to the factory setting happens via the AT command ‘AT&F’

Maybe this could help https://forum.sierrawireless.com/viewtopic.php?f=116&t=1907&p=11683&hilit=10k#p11665

Thanks for the quick reply.

Yep I have seen the documentation LED. But it does not tell me anything about LED ON at power on and then OFF.
The FXT 009 has power. No I did not turn it off since I cannot communicate to it.

Yep I am connecting to the right usb port. That is how I got it working before the download attempt.

That will not help since I cannot communicate to the FXT 009.

Thanks for some of the topic you suggested I review. Everything suggest to send a specific AT command. I cannot access the FXT 009 via USB. So I cannot send an AT command.

Any other suggestions?
Is there a hard reset?

Thanks a lot for your help.

Ok I already thought that sending AT commands would be the problem. Can you connect via RS232 to the FXT009 and test if you can send AT via rs232?

Please can you just elaborate on what are the concerned FW versions (I mean the original one which was running on the module, and the new one you were attempting to download)?
I’ll go back to you ASAP, when I get more details from the embedded software team about this particular use case.

Even when the Firmware download fails or is canceled, the bootloader is still alive and is supposed to listen to the last port used to trigger a download.
The bad point is that DS is not able to handle this recovery mode.
To recover your modem, please try to open the connection on the USB port with another communication software, and to send several “a” characters. Bootloader may need this to synchronize on the port. As soon as you can see chars echoed back, it will mean that you’re in the bootloader AT interface mode.
In this mode, you can only use AT, AT+WDWL and AT+CFUN=1 commands
To recover the firmware, you’ll have to send AT+WDWL command, and use the communication software to download the FW DWL file (matching with your product) in 1K XMODEM protocol. Once the file sent, you’ll have to use the AT+CFUN=1 command to go back to the FW.

Please tell if you still have issues.

FW versions out of the box prior to download attempt: FW
Tried to download: FW Download hanged up, then cancelled and still had communication via USB.LED on FXT009 was still blinking on and off.
Then tried download: Download hanged up, then cancelled and lost communication via USB and LED on FXT009 turned off by itself.
Attempted cycle power on FXT009, cycle power on PC, but nothing. When powering up FXT009, LED comes on for 1 sec or less and then goes off and stays off.

Tried communication via serial port, but no communication there either. And I know before it was working. I am using Putty on windows Vista: baud 115200, data bits 8, stop bits 1, parity none, Flow control RTS/CTS. And this is supposed to be the default for the serial port.

So right now I am not sure the bootloader is running. I have no way to check since none of the ports are working.
So I am wondering of an easy way to hardware reset the FXT009 to factory default (like a hard reset switch)?

Thank you everybody for your help so far. I am confident we can get to the bottom of the issue and get this resolved.

Thanks a Bunch!

I used device manager from windows 7, trying to query the FXT009 here is the error I get:
The modem failed to respond. Make sure it is properly connected and turned on.

I know my USB port is working. I know my USB cable is good. So the only thing that is not working is the FXT009.
I then tried Putty on windows 7: I get "Unable to communicate to COM5. Unable to open serial port.

I checked device manager to make sure that COM5 was the port where my USB cable was assigned to.

So I cannot send anything right now from any port: serial or usb. The thing that is strange is my LED is off even though I know the FXT009 has power. When I turn it on, the LED come on the goes off and stays off. That state/transition is not documented. I think this is a clue. So far as long as the LED is off I have not been able to communicate with the FXT009 form any port what so ever. So that why I am looking for a way to do hardware reset. So far every solution requires communication and I do not have any communication, which by the way I had before through USB and serial port.

By the way I have and FXTE02 extension card installed for Ethernet communication. I do not know if that has any effect in the issue or in resolving the issue.

Thanks a lot for all your help!

The LED going from ON to OFF after reset is a typical symptom of a module “blocked” in bootloader mode.
And it shall continue listening on USB.
So I would say that it sounds like a PC-side issue it you can’t open the COM port associated to the device… Maybe a driver one?
A simple question: before trying to download, did you switched the module USB mode in “COM” mode? This will help to know which driver is enabled on your PC.
Can you make a try to keep the Windows’ Devices manager opened, and unplug/replug the module USB cable, to confirm that your COM port associated to the USB device is disappearing/reappearing?

Why would the module be blocked in bootloader mode? The boot loader should always be there and working, or reset on power cycle. This does not give me a good feeling. That is not reliable at load!

Yes the com port associated to the USB device is disappearing/reappearing, when keeping Windows’ Devices Manager opened. However Windows Devices Manager identifies COM5 while Developer Studio 2.1.1 shows COM1. I am not sure if it should show COM5 instead?

I am able to open and close the port. That is not the issue. I can put another device and it works fine. When I connect the FXT009 module, the com port is open, however the module is not responding. If the bootloader is blocked, I am not sure how the module can respond to a request through the USB port. Also I used the RS232 port and putty for simple basic connection on another computer, and no communication. Thought this was working before the download attempt.

Like I said before, I can open the port (RS232 and USB) but no communication. The module is not responding to any commands.

I am really surprise that there is no way for hardware reset to factory default!!! If I cannot talk to the module because it is stuck, now what???

What I was meaning by “blocked” is that it doesn’t boot on the Firmware, because the Firmware is absent or corrupted (this may occurs if the Firmware download is interrupted/canceled before the end). Actually the bootloader mode is handled by a tiny piece of software, with a small AT commands set and the ability to manage XMODEM download. Even if “blocked” in bootloader mode, the module shall always be able to perform XMODEM download.

So now, here is my understanding of your situation:

  • the module is probably is bootloader mode, keeping listening only on USB port. We can say this because of the fact that your COM5 port is disappearing/reappearing in Windows’ Device Manager when you resets the module --> it means that the bootloader is up and running the embedded USB stack, letting the device to be identified by the PC.
  • So, this mean that you can’t communicate with the bootloader on RS232; bootloader is listening exclusively on one port, and here we know it’s the USB one (because of the first point)
  • it seems that DS has troubles to find the COM5 port. It is a bad behavior of the USB driver in modem mode. But actually, because of a bug we have in 2.1.1 (planned for fix ASAP), even if the port was seen by DS it wouldn’t be able to communicate with it because it is blocked in bootloader mode.
  • The conclusion is: you should concentrate on keep on trying to communicate with the bootloader, in USB (on COM5), and using another communication software able to handle XMODEM download (legacy Windows HyperTerminal app, or other softwares like TeraTerm or Termite… Unfortunately putty can’t do XMODEM). The important thing to notice is that as soon as the module resets, you have to close and reopen the port in the communication software, because a reset makes the port disappearing and reappearing. DS handles this transparently, but here we can’t use it (cf. before).

The steps you should try to follow now:

  • close all communication software
  • reset the module
  • confirm that COM5 port (linked to “Sierra Wireless Modem” device) disappears and reappears in the Windows device manager
  • open COM5 port with a communication software able to perform XMODEM download; don’t take care of the baudrate, it doesn’t mean anything in USB.
  • try to send AT commands, and go the XMODEM download procedure I mentioned before.

Hope it will help; please post if you still have issues…


Yes I agree and confirm that.

Yes I confirm that. Actually when you do a download using Developer Studio through COM5, it hangs at: “Target Rebooting” and never ends. I waited 30 min and cancelled the download. This is what has created the original problem. I was able to duplicate the problem. As soon as you cancel the download the module FXT009 goes in bootloader mode, no firmware.

OK I downloaded clearmodem (free xmodem from ClearConnex). No hyperterminal in Windows 7. I was able through USB port to send basic AT command: AT, AT+WDL and download the firmware and I was back live.

Developer Studio is flacky and unstable. Can I use the previous version? Where can I get it?


Thanks everyone for your help!

Actually, the USB driver (from 3.8.2) can works in two modes:

  • a MODEM mode (the legacy one), recognizing the device as a modem, allowing to setup a dial-up connection from Windows. It’s a fact that this mode is pretty unstable, particularly because of the “modem” layer, completely useless for Developer Studio.
  • a COM mode (new one, introduced in 3.8.2 driver, and usable with FW >= 7.45), where the device is simply seen as a serial port (no “modem” layer anymore).

To enable one mode or the other, a modification has to be made on the target, making it sending the right PID (product identifier)
This modification is suggested by DS in the target status view (cf. displayed warning), if it sees that the target USB port is opened and still in MODEM mode (what will be the case for all legacy modules & FW versions). And anyhow, you can switch the mode at anytime using the control in target status view.

It is strongly recommended to switch to COM mode before any USB download
(if possible, i.e. if running FW version is already >= 7.45;
if not, FW upgrade should be addressed through UART, and then USB mode should be switched to COM mode).

What is the equivalent AT-commands for doing the above?

cf. AT+WUSB command
The module PID can be changed by sending:

  • AT+WUSB=2,0,“1000” command (+reset) to switch to COM mode
  • AT+WUSB=2,0,“1234” command (+reset) to switch to MODEM mode

Please note that as soon as the module resets, the corresponding COM port has to be closed, as it will disappear from Windows “point of view”. The COM port identifier will never be the same for MODEM mode or COM mode, so the switch operation implicates to close the “old” one and to open the “new” one.

If you’re using DS to do the switch, this close + refresh ports list operation is automatically managed, except if this is the first time you do the switch to COM mode. In this case, the new driver has to be enabled on Windows side, and the ports list has to be manually refreshed when this activation is completed.


I have a problem with FXT009:
After some hours of normal operation, it does not respond to AT commands anymore and the modem must be disconnected from the power to restart it.

I have found the same problem in diafaan.com/reviews/sierra- … gsm-modem/

Update: We have received reports from a few of our customers that the Fastrack Xtend FXT009 sometimes hangs after a number of days of operation. It does not respond to AT commands anymore and the modem must be disconnected from the power to restart it. The problem seems to be related to compatibility with the mobile network, in most situations the modem worked fine for years and the hang-ups started after a technical update to the mobile network.

I already updated the firmware version to last release, but the problem persisted.

Someone have the same problem? Do you have any soluction?

How did you fix your problem?
I am having the same issue with Rogers in Canada.