Leaf getsrc swi-linux

I must be missing something obvious, and it’s entirely possible my company firewall is not helping me, but I can’t for the life of me get the linux source to fetch to my development machine.

I’m getting the hang of navigating with leaf and I can setup profiles and fetch legato source no problem, but when I try and get the swi-linux source it continually fails at “Checking credentials…”

target is a WP7601, so I’ve tried both swi-wp76_4.0.3 and swi-wp76_4.5.1 packages.

What am I missing here?
Is there a block on my account (e.g. required NDA)?
Is the GERRIT_USER my email or user number? (although neither is working at the moment)

Hi Nicholas,
It seems that you did not add ssl-key to gerrit. GERRIT_USER is account that you log in to https://gerrit-legato/


When I go here: https://gerrit.legato.io/settings/#SSHKeys I show that I have 2 SSH keys added, and they’ve been there since I’ve tried with 2 of my machines.

Those links that you’ve provided look like internal URLs for your internal DNS? is https://gerrit-legato the same to you as https://gerrit.legatto.io is to the rest of us ?

When I go to gerrit.legato.io and login I don’t have a My option or menu item to click on. I’ve been managing SSH keys through the gear at the top right.

Could you help to provide the log when you execute command “leaf getsrc swi-linux”?
And after add ssh-key on gerrit.legato.io, make sure that you set correct GERRIT_USER in your machine
leaf env user --set GERRIT_USER=“your-account”

And one important thing: " Once you have an account click on Sign In and enter in your user name and password.

After you have successfully signed in click your user id in the right hand corner and choose Settings

Under the Profile settings enter in a user name (it must be unique for the site). This will be the user name you use to connect to Gerrit through leaf"


1 Like

I did not have a username set. It was not set by default and I didn’t find any references to setting it up in the available documentation. However, I’ve set that gerrit username on the settings page and it’s still not working.

I will note that at this point, it may be my corporate firewall. I’ll try again on a non-attributed network and report back.

here’s my log, although it’s not particularly useful:

test@laptopvm:~/myWorkspace$ leaf getsrc swi-linux
Run sync steps for wp76-linux-src_SWI9X07Y_02.28.03.05

Ready to sync in /home/test/myWorkspace/swi-linux-src directory:
repo init -u ssh://nick@gerrit.legato.io:29418/manifest -m mdm9x28/tags/SWI9X07Y_02.28.03.05/linux.xml -g default,-cache ; repo sync

Proceed? (Y/n)

Checking credentials…
ssh_exchange_identification: read: Connection reset by peer
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
Something went wrong when trying to connect to ssh://nick@gerrit.legato.io:29418/manifest
Please check connection and credentials
Then try again leaf getsrc swi-linux

OK, I’ve got it working now. The combination of not understanding which value to use for GERRIT_USER combined with a firewall blocking SSH really had me chasing my tail.

1 Like