Internet through GPRS using Integra or Fastrack


#1

Hi everybody,

I cannot access internet with the GPRS above.
The SIM card works properly using it in a cellular phone (I have been well helped from the SIM company).
I have to install those GPRS under “windows xp” telling that I have a generic modem connected to the serial port COM1. The modems are correctly installed, checked and works properly. I put the inizialization string in the installation tab to get connected through GPRS.
Then, composing the *90# number to start the connection, right after seen the prompt “connected” the connection has been lost. Then retrying to connect, I get error number 718 or 787 and there is no way to get again the message connected until I restart the computer, and everything re-starts from above.
Those errors tells me that the driver may be wrong: anybody had the same problems?

Thanks in advance to everybody.

Hi.


#2

Hi GianniP,
I too had experienced a problem similar to yours.
Before connecting to the service provider, please give AT+IPR=0 command from hyperterminal (to enable the autobauding). Also, remember to create a PDP context by using AT+CGDCONT command. A PDP context will define the
GGSN which should be contacted to in order to connect to the internelt. Now use the dialup connection of Windows to connect to the service provider.
In my case, I have to dial 99**1# (1 corresponds to the PDP context ID which I created using AT+CGDCONT command).

Best Regards,
Open AT Fan.


#3

Thanks Open AT Fun,

unfortunately all your suggestions doesn’t works.
Do you have any other idea?
I still get a 678 error when trying to get connected. May it be cause of non-updated “generic modem driver” (I have WinXP SP2)?
+CGDCONT is ok also because I put the initialization string in the modem configuration. Then I also checked through hyperterminal and the parameter is correcly stored: this is the answer:
+CGDCONT: 1,“IP”,internet.wind.biz",0,0
That is really strange: two modems that doesn’t work. :cry:
ATI3 gives me back: 651a09gg.Q2406B 1480856.

Any other suggestion?

Thanks again, GianniP


#4

I do not understand how, but now it works.
Is probably because of some combination of the following parameters?
+WGPRS: 0,1
+WGPRS: 1,0
+WGPRS: 2,0,1
+WGPRS: 3,0
+WGPRS: 4,10
+WGPRS: 5,0
+WGPRS: 6,0
+CGREG: 0,1
+CREG: 0,1
Also I re-programmed the Integra module with the same files that was already programmed with. May be for this?

Thanks to anybody will reply.
Regards.