Import 1.1.2 Project into Dev Studio 1.2.0


#1

I installed Dev Studio 1.2.0, and tried to import a Project from version 1.1.2.
It failed; loads of compile errors due to not finding headers and a Java null pointer error when I try to just look at the project properties.

Figured this could be because I hadn’t installed the necessary Software Suite Package, so did that - but still the same errors.

Then restarted Dev Studio - and it worked!

Is it expected that a restart is required after adding Software Suite Packages?


#2

Please give more details from the error log about this NPE.
But this should be a known issue: we have indeed (lately :frowning: ) detected an issue when importing a 1.1.2 project into 1.2.0, if depending packages are not installed. To get out of the issue, you indeed have to install the missing packages and to restart Developer Studio.

Some notes:

  • problem doesn’t occur when upgrading a DS 1.1.2 install (since packages stay installed after the upgrade)
  • if you want to keep both 1.1.2 and 1.2.0 installs, you can save disk space by making them pointing to the same location for packages installation