How to stop wind responses?


#1

Hi to al,

       Actually i am connecting a serial LCD to UART1 of wavecom Q24 extended.i can display the strings sending from UART1 by means of adl_atSendResponses...

But my problem is LCD is displaying the unsolicited responses also which are coming from wavecom core software…How to disable this responses? OR suggest me with any ideas to proceed in this issue…


#2

The AT Commands manual tells you how to control +WIND responses.

Note that you have to issue the command manually before starting the open-at application; you must not have the application do it with, eg, adl_atCmdCreate - See: viewtopic.php?f=3&t=3734&p=14521&hilit=inner+at+commands#p14521


#3

Hi awneil

thanks for the reply… i gone through the AT Commands Interface guide.

Syntax is

AT+WIND=

0 no unsolicited "+WIND: " will occur (default value)

So i gave AT+WIND=0. i restarted the wavecom.But still i am getting the unsolicited responses when my application is started
i thought of getting +wind:0 as response when i gave at+wind?, but i got response as +wind:32763

at+wind?
+WIND: 32763

It is also mentioned we no need to save the settings by giving &w command as they automatically store in EEPROM.


#4

Anyway it is a bad idea to use wavecom’s UART this way. There always will be some invalid data: unsolicited responces, ring indications, etc. I think it is better to set some kind of controller on LCD which will filter all unnecessary data.


#5

It should be possible to disable all these outputs!

Giving AT+WIND=0 before starting the application certainly works for me.

Note: it does seem that the “inner configuration” persists if you stop the application; therefore, you have to re-issue AT+WIND=0 before every AT+WOPEN=1:angry: