How to Stop the Application in Infinite Loop


#1

Hi

    I put the infinite loop in my code, and dump the code in Fastrack Supreme. It is running continusly. I am not able to stop the application. Even i tried by pasting continuously the AT command "AT+Wopen=0"  on the Hyperterminal still i am not able to stope.Please reply to me how to stop the application.

#2

If it has an infinite loop, it should be rebooting continually - approximately every 8s or so, each time the watchdog fires…

Please describe exactly the symptoms you are seeing - including what the LED is doing…


#3

Hi Below i was sending the Link, It contain the snapshot of the Hyperterminal.
uploading.com/files/JSMTI1D2/123.bmp.html
I am getting this message “App Starting Please Wait 10 Seconds” continuously. And the LED is blinking very slowly, I am not sure what’s happening.
Please tell me the solution.

Thanks&Regards
Arise


#4

Hi,

            I am sending the link, hope it gives clear idea to you, to give suggestions to me. 

uploading.com/files/K2ASI06P/Snap1.bmp.html
Please tell me how to stop the application. And clear the flash. If you need further details please tell me.

Thanks&Regards
Arise


#5

You can now attach files to your forum posts - see the ‘Upload attachment’ tab just below the Save/Preview/Submit buttons.

But don’t use .bmp files - they will be huge! :open_mouth:

Use a compressed format such as GIF or PNG
(JPEG is probably not good - it’s designed for photographs).


#6

Hi Awneil,

       I have attached the snap shot of symptoms that i  have seen on the Hyperterminal while the application is running on Fastrack Supreme -  The LED is flashed on and off continuously, When the LED is on, at  the hyperterminal i am observed this

+Wind: 13se Wait1
+wind: 12
later “App Starting Please Wait 10 Secondssg Plea” Symptoms are i observed. Could you please give the suggestions how to break this loop and clear the flash.

Thanks&Regards
Arise


#7

If it’s really not noticing AT+WOPEN=0, then you need to reload the firmware using DWLWin.

You did remember to include the Carriage Return when pasting the command, didn’t you?

The firmware is not yet available for download from the new Wavecom site, so you will have to get your distributor to do this for you.

I always make my applications have a delay at startup precisely so that I have a chance to type AT+WOPEN=0 to stop them…! 8)


#8

I don not think it is necessary to reload firmware, just deleting the OpenAT application itself (by checking only “Open AT Application” box in “Erase” group in DWLWin) should be enough. The board then need to reset and new application uploaded.


#9

Hi!

I have some problem with DWLwin, and modem.
My modem (Fastrack M1206B) didn’t accept any AT command, I don’t know how to communicate with modem. I need to reflash firmware, but how with DWLwin? DWLwin always tell me that I need to reset de modem, but how, if it don’t communicate with me.
I tried to use hard reset, but the problam hasn’t solved…

Sombody ideas?

thanks


#10

Hello, I got the same problem with my app: continuously entering in +wind: 12 & +wind: 13, and DWLWin can’t access the device, and no at command works via serial link

thanks for any help, I’m stuck


#11

Hopefully, I found out the solution :

you need a special serial cable, with a red and a black button

  • push and hold the black button : this keeps the modem shutdown and prevents it from rebooting
  • still with the black button pressed, click the ‘start’ button in the DWLWin interface, so that DWLWin start trying to erase the flash and download the firmware
  • still with the black button pressed, push the red button : the DWLWin process starts.
  • keep the black button pressed until the flash is erased.

#12

Clearly, it’s not the colours of the buttons that are important - it’s how they are connected that matters! 8)

Without giving specific details of the supplier and part number of this “special cable”, and/or its wiring, your description is meaningless. :unamused:

From your description, it sounds like your “red button” controls the BOOT signal, and your “black button” controls the RESET signal :question:


#13

they seem to have fixed this problem in the q2686 with firmware 7.x
if i manage to screw up my program, the device restarts 8 times and then gives up on the application.
it’l report at+wopen=1, but the program doesn’t run.


#14

Hi All

Mee to stuck up with the same problem.

In my custom application i want to use UART1 as serial port to collect the data from the remote device and send the data to the remote server using GPRS.

I was in the process of initilazing the UART1. I have registerd FCM, wrote data and CTRL Handler for the same. I have downloaded the application. But i forgot to include the code for UART1 to come out of DATA mode to respond for AT commands.

NOw i am trying to download the new application, but modem is not responding for TMT.

I would like to know is there any master reset to erase the application Flash Memory, Or

Do we have any control signal to make the application not to boot from FLASH.

My ultimate aim is to download NEW application into the Flash memory.

Experts pls help me in solving this.

Thanks a lot in advance.

regds
KR


#15

Hiya,

Essentially, you will have to use the DWLWin tool and follow the appropriate instructions to put the module into BOOT mode so that DWLWin can talk to it. The method of putting the module into BOOT mode varies - check your doco.

DWLWin will let you then either erase the application, or completely re-flash the module to the latest firmware. See the notes earlier in this thread.

Detailed instructions on doing this are in the Firmware release notes - available in your OpenAT install under firmware, or if you can’t find them there you can download the release docs from the Wavecom download site.

DWLWin is also available from the Wavecom download site.

I strongly recommend having a short start-up delay before launching into your application, as noted elsewhere in this forum.

ciao, Dave


#16

Dear Dave,

I tried with DWL tool.

But i received following error message

“Boot failure: unknown baseband or unexpected answer received
Cannot boot up the remote target: autodetection failed”

I am using wavecom fast track supreme 10 modem. I would like to know whether DWL will support for this modem.

pls help me in closing this issue.

Thanks a lot in advance

regds
KR


#17

Hiya,

DWLWin works with both the Fastrack Supreme 10’s I currently have on my desk - one with a Q2686H, one with a Q2686G.

This means that the Modem is not in BOOT mode, or the serial port settings are incorrect. To put the modem into boot mode, you have to connect the BOOT pin to GND via a 10k resistor while powering up the modem.

Before you start with DWLWin. you will need to obtain (or make) an appropriate cable to provide access to the BOOT pin on the HD15 connector on the Supreme. I’ve made my own adapter with a pushbutton switch to enable me to do this reliably.

Here’s the steps that I follow to delete the application from a modem:

  1. Download DWLWin from Wavecom developer area and install on PC.
  2. Obtain (or make) cable described above to enable simultaneous RS232 and Access to the BOOT pin on the Fastrack Supreme.
  3. Start DWLWin.
  4. Configure Serial Port Settings appropriately.
  5. Make sure that no firmware files are checked. This will ensure that only the application & data will be erased.
  6. Make sure that only OpenAT Application in the Erase list is checked.
  7. Set Wireless CPU Type to AutoDetect
  8. Click on the Start button. DWLWin will attempt to connect to the modem a number of times. Don’t worry if you get a couple of Aborted attempts at the beginning while you do the next couple of steps.
  9. Connect the BOOT pin on the Supreme to GND via a 10k resistor
  10. Power up the Supreme
  11. DWLWin will now connect, and start installing the downloader to the Module. You can release the BOOT pin connection once this occurs.
  12. DWLWin will now delete the openAT application and complete

Let us know how you get on.

ciao, Dave


#18

Dear DAVE,

THANKS FOR YOUR RESPONSE.

But I am not having such a cable. Where I can get the same.

Is it possible for me to check out the same from elink. Or do i need to contact the distributor.

Pls advice me on the same. If its not possible i would like to how to create one such cable.

Thanks once again for your response.

regds
KR


#19

Your distributor should certainly be able to help you

The connector pinout is given in the Fastrack User Guide;
from there, just follow Dave’s instructions…


#20

Hiya,

No problems.

Perhaps I should have said ‘Make’, rather than ‘Obtain’. That’s what I did.

As awneil said, it’s all in the Fastrack Supreme user guide (WA_DEV_Fastrk_UGD_001), section 3.2.1.3
Basically, you will need the following:

  • 1 x HD-15 Male (has pins) connector (solder bucket connections make life a lot easier)
  • 1 x DB-9 Female (has holes) connector
  • 1 x 10k 1/4 watt axial resistor
  • 1 x small Single Pole Normally Open (SPNO) push-button switch
  • appropriate cable
  • Soldering iron and solder
    A small vice is useful to hold the connectors while soldering.

Construction Steps:

  1. Follow Table 2 (Sub HD 15-pin connector description) to wire the RS232 pins from the HD15 connector to the DB9 connector. The connection is DCE ‘Straight through’ (i.e. HD15[TxD] goes to DB9[TxD]).
    The easiest way to work out the correct pins is to use a multimeter and test your existing interface cable.
  2. Trim and Solder one end of the resistor to one terminal of the push-button switch
  3. Strip the end and Solder a short length of insulated hook-up wire to the other terminal of the push-button switch
  4. Trim and Solder the other end of the resistor to Pin 3 of the HD15 connector
  5. Strip the end and Solder the other end of the wire connected to the push-button switch to Pin 9 of the HD15 connector
  6. Make the whole constriction tidy and ensure that no inter-pin shorts are possible

That’s it. Follow the instructions posted earlier to erase the application from your modem.

ciao, Dave