How to get the WP7607 device to work on Linux?

Yes,How do you think about writing a completely new drivers to replace the qcserial and qmi_wwan drivers to use the WP7607 module?
Do you think it’s feasible?

what is the purpose of this to replace a workable driver?

Because original purpose of my team is develop driver for WP7607 module, however was available drivers to use , but i don’t know my team will use it or still develop new drivers. In case develop new drivers, Do you think it’s feasible?
I know you’re an expert , So I ask for your opinion.
Sorry for hard to understand !!

Then why don’t you discuss with your team?

Not quite sure what you are really asking for …

1 Like

Ok, I will discuss this issue with my team, then if has any problem I hope will get your support :smiling_face_with_three_hearts:
thanks you so much

Hello jyijyi,
qmi_wwan driver be loaded for rmnet0 interface of my module, So if I only have qmi_wwan driver ( No qcserial driver ) Can I test the data connection setup as your tutorial?
thank for your answer!!

Did you also install the mbpl usb driver with qmi_wwan.c ?

If you don’t have qcserial, you need to try the connection manager application in mbpl SDK

1 Like

Yes, so if I don’t have qcserial , I still can test data connection with connection manager application and qmi_wwan driver, right?

Didn’t your qcserial already work?

Hi, I want to know, for the data connection establishment feature, do I only need qmi_wwan or both drivers to test that feature?

If you need to type at!scact, you need qcserial

I think you better have some testing to verify your question

1 Like

Hi iyijyi,
Such as I mention about we want to develop new driver for my module, purpose of this work is help we more understand about how to development driver for any module, So I think I will start with a new driver with same feature qmi_wwan ( we will develop based on our understanding ) and then check data connection establishment feature before develop other driver same feature qcserial to use other feature , So that is reason I ask about ,Can work with only 1 driver similar to qmi_wwan for data connection establishment feature?
Thank you so much!!

Did you platform have qmi_wwan?
If yes, there is really no need to develop a new driver

If you develop a new driver, what if it does not work in some situation in the field, what will you do?
No vendor will support your driver written by your own, you need to take all the risk

1 Like

Yes , I know, thank for your reminder, I don’t know the correct way to program it , I’m learning about network driver programming because as far as I know qmi_wwan is a network driver.

Hi jyijyi,
qcserial attach ttyUSB2 device port for NMEA port of my module , but when I enter ( echo -r"/$GPS_START" > /dev/ttyUSB2" or cat /dev/ttyUSB2 ) did not receive data , Even though I have printk logs in each function of qcserial and know they are called in the dmesg log when I enter the above commands, but it still not receive data, my concern is:

  • Is the command I used to call GPS data correct?
  • If true, is the problem qcserial or is the firmware version mismatch affecting me receiving GPS data?
    Thank for your response!!!

/dev/ttyUSB2 should be the AT command port

To see the nmea frame in nmea port /dev/ttyUSB1, you need to enter these commands in AT port:


I can only use at command in ttyUSB0, not in ttyUSB1, ttyUSB2

Then you can see if there is nmea frame in ttyusb1 or tthusb2 after entering those AT commands

Thank for your suggest , tomorrow I can test it, but if it still not receive data, Where do you think the problem lies, driver or module or firmware.

Maybe you try it first

1 Like