How to enable RLC Unacknowledged Mode (UNACK)?


#1

Hello all,

I’m creating a VOIP application in OpenAT running on an SL808xT module.

I’ve read a lot of whitepapers on how to improve VOIP performance on HSDPA networks. They all mention the RLC can work in “Unacknowledged Mode” which is preferable for VOIP (particularly when moving) as it disables retransmissions.

My question is, how do I request “Unacknowledged Mode” when initiating a data connection using OpenAT on the SL808xT module?

Thanks and happy christmas!

David


#2

Hi David,

Maybe a bit late but the RLC is lower layer that OpenAT may not able to access.
For such purpose, best fit could be to configure the Quality of service using +CGQMIN/+CGQREQ command.

For details, please refer to AT command guideline and 3GPP spec.

Hope this helps.
L


#3

It’s never too late; thanks for the reply! I’ll look into those options.

David.