how to downgrade to DS 1.x.x


#1

There is a way to downgrade to old version of DS?
I already tried with eclipse function for restore previous state, but not works.

I need urgently to get the old version, the 2.0 (at least on linux 64 bit) haves too many problems.

thanks


#2

I can’t imagine issues you have under Linux 64 bits with 2.0.0 that you wouldn’t have with any older version.
Please can you make a list of the issues you have that makes you wishing to go back to 1.X?


#3
  1. https://forum.sierrawireless.com/t/cannot-open-project-after-upgrade-to-2-0-0-201103101643-r660/4998/1
  2. I removed the task from the task table for use the old adl_main and I got a nullpointerexception
  3. Then i launched with run as at application, DS downloads the app but the at console is completely grayed
    I must switch on target management -> devices and then click on the serial port (already open)
  4. By refreshing the status of the openat app, the command hangs in ‘Requesting…’
  5. the openat app seems to not start or traces are not shown
  6. still present https://forum.sierrawireless.com/t/error-when-refreshing-ports/4901/1
    This release
  7. by debugging, ds downloads the app, then hangs with the following message:
    Ignoring packet error, continuing…
    warning: unrecognized item “timeout” in “qSupported” response

It would be good to keep the old major version in the update site… in case of emergency…

!ENTRY org.eclipse.ui 4 0 2011-04-14 09:52:54.371
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
at com.wavecom.openat.ide.ebs.ui.editors.CodeGenerationPage$14.elementRun(CodeGenerationPage.java:366)
at com.wavecom.openat.ide.ebs.ui.editors.ElementAction.run(ElementAction.java:77)
at org.eclipse.ui.actions.BaseSelectionListenerAction.runWithEvent(BaseSelectionListenerAction.java:168)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3540)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3161)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)

org.eclipse.debug.core.DebugException: Error in final launch sequence
at org.eclipse.cdt.dsf.gdb.launching.GdbLaunchDelegate.launchDebugSession(GdbLaunchDelegate.java:189)
at org.eclipse.cdt.dsf.gdb.launching.GdbLaunchDelegate.launchDebugger(GdbLaunchDelegate.java:83)
at org.eclipse.cdt.dsf.gdb.launching.GdbLaunchDelegate.launch(GdbLaunchDelegate.java:72)
at com.wavecom.openat.ide.ebs.launch.target.gdb.GdbServerLaunchDelegate.access$0(GdbServerLaunchDelegate.java:1)
at com.wavecom.openat.ide.ebs.launch.target.gdb.GdbServerLaunchDelegate.launchOnTarget(GdbServerLaunchDelegate.java:200)
at com.wavecom.openat.ide.ebs.launch.target.gdb.GdbServerLaunchDelegate.launch(GdbServerLaunchDelegate.java:185)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:853)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:702)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:924)
at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1128)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.eclipse.core.runtime.CoreException: Failed to execute MI command:
-target-select remote localhost:10000
Error message from debugger back end:
Quit
at org.eclipse.cdt.dsf.concurrent.Sequence.abortExecution(Sequence.java:560)
at org.eclipse.cdt.dsf.concurrent.Sequence.access$4(Sequence.java:552)
at org.eclipse.cdt.dsf.concurrent.Sequence$2.handleErrorOrWarning(Sequence.java:424)
at org.eclipse.cdt.dsf.concurrent.RequestMonitor.handleFailure(RequestMonitor.java:385)
at org.eclipse.cdt.dsf.concurrent.RequestMonitor.handleCompleted(RequestMonitor.java:348)
at org.eclipse.cdt.dsf.concurrent.RequestMonitor$2.run(RequestMonitor.java:291)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.Exception: Quit
at org.eclipse.cdt.dsf.mi.service.command.AbstractMIControl$RxThread.processMIOutput(AbstractMIControl.java:824)
at org.eclipse.cdt.dsf.mi.service.command.AbstractMIControl$RxThread.run(AbstractMIControl.java:662)

Request for monitor: ‘RequestMonitor (org.eclipse.cdt.dsf.concurrent.RequestMonitorWithProgress@3c299c45): Status ERROR: org.eclipse.cdt.dsf.gdb code=10004 Failed to execute MI command:
-target-select remote localhost:10000
Error message from debugger back end:
Quit java.lang.Exception: Quit’ resulted in an error.


#4

About the fact to go back to the previous release:

  1. won’t help, the issue is not linked to DS 2.0.0, but that Eclipse 3.6.2 was released between 1.2.0 and 2.0.0 (1.2.0 will have exactly the same issue)
  2. We’ll have a look on this
    3/4/5/6) Related to new Target Management, present from 1.2.0… Maybe these issues are Linux-related; anyway, 1.2.0 had probably the same, and former versions didn’t support TM under Linux
  3. Probably due to the fact that your application doesn’t seem to be alive (Debugger will fail in this case; we’ll add more checks and information in the next one, to ease the diagnostic in such a case).

I don’t think going back to 1.2.0 (or even worse to 1.1.X) would help you regarding all of these points…
Points 3/4/5 may be related to TM usage under Linux; could you confirm if you have the same issues on Windows?


#5

I worked with DS 1.2 and eclipse 3.6.2 without to notice this problem

in fact without defining tasks the apps not works using the old adl_main. For let it work you must define a task that calls adl_main.

if I execute run instead of debug the application runs and the custom at commands answers as expected, so I think the app is alive.
I tried with elf and eabi.

as I said before thos problems may be related to linux 64 bit.
No I can not easily test it on windows.


#6

We’ll push Target Management tests a little bit further on Linux (32/64) to make sure that these points will be fixed in next release (including debugger issue).


#7

I am working with DS 2.1.0 and having the same problems diste has, on Windows 7 64-bit, especially with debugging.


#8

Please can you elaborate on the various issues you have?


#9
  • Environment hangs most of the time when switching to Target perspective. Hopefully restarting DS helps.
  • Attempting debugging, DS downloads the app and GDB terminates with either 0 or -1 result code.
Sending packet: $qSupported#37...Sending packet: $qSupported#37...Sending packet: $qSupported#37...Sending packet: $qSupported#37...Packet instead of Ack, ignoring it
Ack
Timed out.

Then lots of error messages pop up and get cleaned up.


#10

To answer the question in the title, “how to downgrade to DS” - you don’t!

You just make a separate installation in a different folder.

Simples!


#11

About the hanging issues, maybe can you attach the zipped DS log here? (.log file(s) located in yout workspace “.metadata” folder)

Concerning debugging, there are some pitfalls to avoid around the topic.
Please have a look since they all may have been covered in other thread(s):
https://forum.sierrawireless.com/t/cannot-debug-in-embedded-gdb-mode/5088/1


#12

Logs attached.

Additionally, I’m having trouble reprogramming device when at AT+IPR=9600;AT&W. DS has trouble with detecting it when set to static baudrate 9600, and fails at Downloading - Block x/y, Retry count 1 with ‘Rebooting target device’ - which never happens.

However, PuTTY is all too happy to communicate with the modem.
log.zip (71.6 KB)


#13

Maybe all comes from this… Please can you explain why you need to set the target speed at 9600?
Note that next DS release will provide a way to easily change the baudrate “in one click”, both for PC & target at the same time.


#14

I got over the need to set baudrate at 9600. Now everything is working.