How do I send an SMS from the cloud to the Airlink on the factory floor?

I have a server in the cloud ServerA

ServerA Information:
IPv4 Address:
Subnet Mask:
Default Gateway:
DHCP Server:

DNS Server 1:
DNS Server 2:

Factory Floor Airlink:
Device IP: (port 9191)
IP Netmask:
Ethernet Port Configuration: Port 1 → WAN

From the server I can ping the airlink. I can remote into the airlink using and the login.

However, when I send a message from the server (using software Ignition over port 17141/17142) the message never arrives.

I know this isn’t because of the airlink as I can connect directly to the airlink and send messages from a copy of Ignition running on my laptop.

The traceroute from the server to the airlink has 4 hops:

  4. ← this is the airlink

Can anyone explain what I am doing wrong or what settings I have setup incorrectly in the airlink? I am guessing this is related to host port routing settings but I don’t know what I need to set them to.

Hi @bmeyers,

  1. Are you referring to a specific Airlink router?

  2. How do you use Ignition software to send SMS? Please provide more details.
    → I understand that the issue happens when you uses the Ignition software to send SMS, so, if you use a phone or any other device with a SIM card as usual to send SMS to the router, does the issue occur or not?

  3. Which SMS mode is the router currently in?


Good morning,

  1. RV55 (1104302 with Wi-Fi)

  2. The Ignition User Manual describes how the Ignition server is setup and the second link describes how Ignition recommends the airlink RV50 be setup (RV55 is similar). However, not many of the settings in this guide are being used currently since they didn’t allow network traffic.

  1. External devices can successfully send messages to the RV55.

  2. RV55 is connected to local plant wi-fi and also plugged in through port 1. Last night we modified some settings on the LAN tab.

Device IP:
IP Netmask:
DHCP Mode: Auto
DHCP Starting IP:
DHCP Ending IP:
Port 1 Port Mode: LAN

Host Port Routing:
Proxy ARP (Primary Gateway): Enable
Host Network 2:
Host Network Subnet Mask 2:
Host Network 2 Route: Ethernet

Host Network 3: Settings set to default values.

The weird thing is these new settings worked in allowing traffic from serverA to the airlink RV55. However, traffic cannot get from the airlink RV55 to the serverA.

What I don’t understand is why DHCP mode being in Auto would matter? I am happy to assign a static IP address.

The other weird setting is the Proxy ARP being enabled.

And finally disabling any of the routing settings makes the test fail again and no traffic is allowed.

In Auto Mode the manual states:

“Auto - When the router is powered on or reboots, it attempts to determine if a DHCP server is present on the Ethernet network. If a DHCP server is found, the router obtains an IP address from the DHCP server. If no DHCP server is found, the port acts as a bridged LAN connection.”

I am confident a DHCP server does exist however since I assigned an IP address why would I need to obtain an IP address from the DHCP server?

In the Host Port Routing section of the manual

“When enabled, the AirLink router responds to Address Resolution Protocol (ARP) requests to resolve WAN addresses for devices on the connected LANs. In doing so, the router becomes the primary gateway for connected LANs.”

I have this enabled now. However the manual then states:

“Ethernet - Select this option if the network uses a router that acts as an ARP proxy for addresses on subnets connected to it. Note: If proxy ARP is not enabled on the router, the transmission fails (destination unreachable).”

Again, not sure if airlink is responding to ARP from somewhere to resolve the IP address I set the airlink to.

Hi @bmeyers,

If other devices can send SMS to the RV50 successfully, it might be an issue with the server or software.
Therefore, I suggest it’s best to recheck on the software forum or seek assistance from the server side.


Hello, did you get the solution?
I’m having the same kind of problem here, I followed the Ignition manual and didn’t work.
I only can send SMS using PuTTY from the laptop connected to the Airling, I can’t ping from the network.