HL7800 NBIoT no IP

I’m trying to use a HL7800 to connect to a NOIP service. I’ve tried to set

AT+CGDCONT=1,"Non-IP","SCEF",,,,,,,,,,,,1,1

with

at+ksrat?
+KSRAT: 1
AT+KBNDCFG?
+KBNDCFG: 0,0
+KBNDCFG: 1,00000000000000081088
+KBNDCFG: 2,0

I know I have the bands set up right but when I try

AT+CREG=3

I get

AT+CREG?
+CREG: 3,3,,,,0,19
AT+CEER
+CEER: SERVICE_OPTION_NOT_SUPPORTED

Is there anything else I can try?

Hi pboozer

Make sure it supports Non-IP service from your mobile service provider. I can connect to Non-IP service using simulator Amarisoft network on HL78xx.

Firmware version: HL78xx.4.5.4.0
at+cgdcont=1,“Non-IP”,“nonip”

OK
AT+CFUN=1,1

OK
AT+KSRAT?

+KSRAT: 1

OK
AT+CGDCONT?

+CGDCONT: 1,“Non-IP”,“nonip”,0,0,0,0,0,0,

+CGDCONT: 2,“IPV4V6”,0,0,0,0,0,0,

OK
AT+KBNDCFG?

+KBNDCFG: 0,0
+KBNDCFG: 1,00000000000008000000
+KBNDCFG: 2,0

OK
AT+KBND?

+KBND: 1,00000000000000000000

OK
AT+COPS?

+COPS: 0,0,“Sierra Wireless”,9

OK
at+creg?

+CREG: 0,1

OK

Please help to tick “Solutions” if your question is answered.

Thank you for the response Donald.
That’s just the thing, I’m working with the provider to figure out the support. I’ve used the same modems to connect to Cat M1 & NB IoT IP just fine. It’s the NOIP part that is giving everyone trouble. Provider has also requested we try to get a newer version of the ALT1250 firmware, 03, but the available HL78xx firmware on the Source is still 02
Firmware HL7800.4.4.6

It has seemed like the modem is always using Extended PCO IE, even when I turn it off with AT+KCIOTOPT. My provider has stated this is not supported

AT+KCIOTOPT?
+KCIOTOPT:
0,0,0
1,0,0
2,0,1
3,1,1