HL7800 current consumption measurement in development kit


I’m trying to measure current consumption on the HL7800 LTE Cat M1 module.
I’m using the HL78 Development kit, PN 5303247, Rev 2.

Instructions below are from the Development Kit User guide (Rev 3.0):

4.4.2. Isolated Development Kit and Module Power Supply
Follow these steps to only measure the consumption of the HL78xx module (baseband + radio frequency) separately from the consumption of the Development Kit:

  1. Plug power supply VBATT_APPLI on CN800.
  2. Plug power supply VBATT_BB on CN801 (VBATT_RF on CN802 = NC); or plug power supply VBATT_RF on CN802 (VBATT_BB on CN801 = NC).
  3. Unplug jumper CN804.
  4. Plug jumper CN803.

And then placing a true RMS multimeter in series with the Vbatt_BB input , which comes from a bench supply providing 3.7V.

The problem is that I’m measuring about 45mA most of the time, with peaks above 100mA during connections, but the current doesn’t go below that with the PSM and eDRX commands, at+cpsms and at+cedrxs, which return Oks.

I even tried the +CPOF command for power off and the current actually went up to about 75 mA.

Any idea of what I could try to see the lower power consumption in PSM and eDRX?

The firmware version is:

Thanks for your help!


Hi @aislas,
You are using a little older version of the devkit. This devkit is not setup by default to measure current consumption in low power modes.

Devkit revision 4 and later are setup to measure current in low power consumption modes.

For older devkits, you can make the modifications as suggested in the attached document.

AirPrime - HL7800 - Reworking the Development Kit for Current Measurement Technical Note - Rev1.0.pdf (391.9 KB)

Let us know if this helps.

1 Like

I finally had a chance to implement these changes on my eval board.
It worked! Thank you very much.

1 Like

This is a different question, but I’m not sure the system is going into PSM and eDRX for the expected duration.

For example, I did this for an example:

At+cpsms=1 , « 01000111 » , « 00100100 »
• Enables PSM (1)
• TAU timer (T3412) = 70 hours
• Active Timer (T3324) = 4 mins

And I only see the ~10uA current briefly, then it reverts to about 50mA.
Same situation for the eDRX mode.

Is there a way to find out what are the timing values actually accepted by the network, instead of the requested values?

Thanks again!