HL7692 Firmware Upgrade Checksum Error

I am trying to upgrade firmware via USB serial port for the modem HL7692. However I am getting the below Ebl Checksum error when trying to complete this. The version that I am trying to update to is 2.27. The version currently on the modem is 2.24.

image

I have downloaded and installed the firmware upgrade tool: https://source.sierrawireless.com/resources/airprime/software/airprime---hl75xx-hl76xx-series---firmware-upgrader-tool/

I also have installed the USB drivers: https://source.sierrawireless.com/resources/airprime/software/hl854x-usb-drivers/

I can contact the modem currently using AT commands via TerraTerm.

Another point to note is that before running the .exe file for upgrading to version 2.27. I edit the .bat file to the baud rate of 115200 and the port to COM12 which is what the device has been set to.

Can anyone point me in the right direction or have any idea as to what may be wrong?
Thanks.

HI PMcC,

Please try to Power off module by removing power supply, not use RESET pin.
Run FW.exe then power on module.

or try a another USB serial cable.

Thanks for your reply Sierra_kiln1,

I have been previously powering the device off and on by removing the power cable. I also have tried different USB cables and this issue still prevails unfortunately. Furthermore, I have ran the firware.exe and powered on the device as mentioned and this still does not work.

Hi PMcC,

You are using the UART port for the upgrade, no USB port right?
Try to set AT+KSLEEP=2 (to forbidden SLEEP mode), AT&D0, AT&K0 (no hardware flow control0) and AT&W, try again to see if it can help.

If still no luck, maybe you can consider local upgrade with Xmodem File(.dwl), you can get it from source website
https://source.sierrawireless.com/resources/airprime/software/hl7692-firmware/

Here’s the procedure:
AT+WDSI=4095 //enable +WDSI indication
AT+WDSD=932424 //size of FW.dwl file
//Send xx.dwl with HyperTerminal->SendFile->“1K Xmodem” protocol
+WDSI: 3 // downloaded, waiting to install
AT+WDSR=4 //install the package

Hi Sierra_klin2,

Thanks for your reply.
Update on this issue
I have been informed that the specific module I was trying to upgrade, is unable to be upgraded. I since have obtained a new HL7692 module with firmware version 2.23 loaded out of the box. I am using a mangOH green board to test this module and I am trying to upgrade firmware over USB (micro USB). I have completed all steps previously mentioned thus far but I am now achieving a similar error to the following thread: Dev kit HL8548-G firmware
However I tried the troubleshooting steps provided on the mentioned thread and still am not able to upgrade to firmware version 2.27.
Currently receiving the below error. After rebooting the device, I keep getting a timeout error.
image

Hi PMcC,

I can succeed to upgrade with mangOH-green + HL7692 + USB, here’s my log:
Here’s my connection:
WeChat%20Image_20190131115124

With mangOH dev-kit, I suggest you use USB intead of UART.
or you can try with HL dev-kit.

Log file is “C:\Users\klin\AppData\Local\Temp\HL769x.2.27.183100.201808171133”
Use Port: USB1

Intel Command Line FlashTool v.1.37 1.3-r33 (Download Library v.4.140,0.0 )

psi_signed.fls (PSI) (NAND)
slb_signed.fls (SLB) (NAND)
AENEAS_FW_signed.fls (Code) (NAND)
allcpus4eboot_ahb11_signed.fls (Cust) (NAND)
FIH7160_signed.fls (Code) (NAND)
FIH7160-MSY_signed.fls (Code) (NAND)
Booting ‘C:\Users\klin\AppData\Local\Temp\7zSC22B.tmp\temp\psi_signed.fls’, memclass: PSI
-> Please reboot your phone device <-
//Power up

Device synchronized.
Details> Injecting RPSI
Details> Injecting EBL
Details> Boot-loader is active
Details> EBL version: XMM7160_1833.500_M1S1 1833…500

Thank you Sierra_klin1,

I have now managed to successfully download and install the latest firmware. The issue was with the port I was using. I had the port set to COM15 within the entry.bat file. COM15 port was the USB1 port (screenshot below) but I changed the use port from COM15 to USB1 and it worked.

image

Many Thanks!