HL7588 with AT&T, IMS registration for short message service


#1

Hello, I’m running a HL7588 with firmware

RHL75xx.A.2.11.151600.201709111842.x7160_8

I’m running on an AT&T SIM card and have successfully established a data connection using an external pppd.

However, I seem to be unable to send or receive any short messages. The CMGS commands are replied with OK, but nothing ever is received at the destination, and messages to the device seem not to be received, either.

AT+CIREG=2
AT+CIREG?

+CIREG: 2,0

AT+CGDCONT?

+CGDCONT: 1,“IP”,"",“10.242.***.***”,0,0,0,0,0,0

Does this mean that AT&T does not provide short message services to me, and I have to check my subscription details?

Is IMS registration mandatory to send and receive short messages?

Can I/do I have take additional steps to achieve IMS registration?

AT+CGCLASS?

‘+CGCLASS: “A”’

Can I/do I have to manually select CGCLASS to be able to do data and short messaging simulteanously?

Grateful for any tips


#2

Dear Sedel,

You should be able send SMS if the SIM/account supports it. Are you able to send a SMS using the same SIM with your cell phone?

Can you also provide output for below commands:
AT+COPS?
AT+KBND?
AT+CEREG?
AT+CREG?

To send SMS:
AT+CMGF=1
AT+CMGS=“phone number”

text
CTRL+Z

Hope this helps.


#3

I am running into a similar issue. I am sending AT commands via a microcontroller to an HL 7748. Everything looks like it worked, but I do not see the SMS appear at the destination. I am using a NEO CAT M1 sim card. I register the APN successfully, when I do a +creg, it is registered. For +cops, I see it on the AT&T network. I then enable SMS mode with +cmgf =1. I then send the +cmgs with phone number, and get the “>” character in response. I send the message, followed by the ctrl-z character, and when I do a read I get a +cmgs:XX, where XX is the message ID. But I never get anything on the other end. I thought my phone number might be bad, so I tried with country code, without country code, and many other combinations with no luck. I am going to try to setup a TCP connection today to see if that works.