AT&T IMS registration on HL7688 4G module

I am using the HL7688 4G module. I am sending AT commands via a microcontroller to an HL7688.
at+cmgs="< number>"

hello

+CMGS: 8

OK

Everything looks like it worked, but I do not see the SMS appear at the destination. I am using a AT&T sim card. I register the APN successfully with attiotdemo.
when I check the registration of SIM, it is registered.
at+creg?

+CREG: 0,1

OK

at+cereg?

+CEREG: 0,1

OK

For +cops, I see it on the AT&T network.
at+cops?

+COPS: 0,2,“310410”,2

OK

also not able to get the SIM number,
at+cnum?

+CME ERROR: 3

So, it looks like SIM is register but not able to send and receive the SMS also not getting the SIM number.

Any idea why it is not working!!

Hi @varun.sahni,

You could check the phone number if it is written to SIM by command

AT+CNUM

Please note that, this command does not have the question mark at the end.

Could you please try to send the following commands and share with me their responses? According to the responses, we will have more information about the issue you faced

ATI3
ATI9
AT+CCID or AT+ICCID
AT+CREG?
AT+CEREG?
AT+COPS?
AT+CMGF=1
AT+CSCA?
AT+CMGS="< number>"

In case the destination is also a HL7688 module. To see the SMS appear, please make sure you have enabled the SMS notification

Thanks,

Hi Donald,
Thanks for the quick reponse,
i tried these commands,
at+cnum

OK

at+cnum

OK
at+creg?

+CREG: 0,1

OK

at+cereg?

+CEREG: 0,1

OK
at+cops?

+COPS: 0,2,“310410”,7

OK
at+cmgf?

+CMGF: 1

OK

at+cmgs="+1651XXXX"

+CME ERROR: 3

at+cmgs=“651XXXX”

hello

+CMGS: 6

OK

at+cmgs=+919XXXXXX

+CMS ERROR: 303

at+cmgs=“90212XXXXX”

hello

+CMS ERROR: 38

How can i enable the sms notification?

Hi @varun.sahni,

Please make sure the below things for sending SMS successfully.

  1. SMS service is available for used SIM. If you do not know about this, please help to check with your SIM operator.
  2. The SMSC value is set. Refer to command AT+CSCA at page 179 AirPrime - HL76xx - AT Commands Interface Guide
  3. Please try to send SMS text message to your phone for testing first.
  4. If 3 above steps are successful, please try to send SMS to another HL7688 module again.

SMS notification can be enabled by AT+CNMI command page 177 in above document

Thanks,

  1. we are using ATT SIM card, it does not allow to send SMS directly.we have to use some kind of Service center.
  2. I also tried to send SMS over service center but it is not wokring,
    at+cmgf=1
    OK
    at+cmgf?
    +CMGF: 1

OK
at+cmgs=“53340003”.
+CMS ERROR: 303

but you can see gprs setting is working fine by following commands,
at+cgdcont?
+CGDCONT: 1,“IP”,“m2m.com.attz”,“0.0.0.0”,0,0,0,0,0,0

OK
at+cops?
+COPS: 0,2,“310410”,2

OK
at+cgatt?
+CGATT: 1

OK
at+cgreg?
+CGREG: 0,1

OK
at+creg?
+CREG: 0,1

Hi varun.sahni,

Can you please help to try below command

  1. AT+CSCA?
  2. AT+CREG?
  3. AT+CMGF=1
  4. AT+CMGS="< your phone number>"
  5. Once the “>” appear on your terminal, please enter “hello” then crtl-Z
  6. Check that SMS is received on your phone

If you do not receive the SMS message on your phone, please share with me the log of above commands

Thanks,

at+cgdcont?
+CGDCONT: 1,“IP”,“m2m.com.attz”,“0.0.0.0”,0,0,0,0,0,0

OK
at+cops?
+COPS: 0,2,“310410”,2

OK
at+cgatt?
+CGATT: 1

OK
at+cgreg?
+CGREG: 0,1

OK
at+creg?
+CREG: 0,1

OK

at+csca?
+CSCA: “+19703769800”,145

OK
at+cmgf?
+CMGF: 0

OK
at+cmgf=1
OK
at+cmgf?
+CMGF: 1

OK
at+cmgs="+919424782002"

hello

+CMS ERROR: 38

Still i did not receive the SMS.

Hi varun.sahni,
You are using AT&T SIM card and registered to AT&T network. However, the Service Center Address for SMS service is not correct. That’s why the message cannot be sent successfully

According to AT&T website, the SCA should be “+13123149810”, not “+19703769800” as your showed.

Could you please try to set SCA again?

AT+CSCA="+13123149810",145

then reset module. After reset, I think you can send SMS successfully.

Thanks,