HL 6528RD-G2.8V no MQTT conn. to airvantage

Hello guys,

I have a working HL 6528RD-G2.8V from the dev kit currently at my desk. I have followed the Arduino tutorial to get it to work. I set up the system and get debug info through a second arduino. This all works fine, but when I run the arduino sample code and fill in all the neccesary details in the code, the device returns the following message:

---- FAIL MQTT Connect ----
Please register your module on AirVantage por chPsr
Module Ty LR28Serial Num:M517
IM⸮I: 01503

There are certainly some characters missing here, but that’s not the point. So I followed the step-by-step tutorial on registering the device on airvantage. I also got the Alarm code hooked up as an App in the airvantage console and used the same password as defined in the arduino code. I have run everything serveral times but the debug output keeps saying that i have to register the module.

I even see the device show up in the airvantage console, but it just wont connect over MQTT.

Can anyone assist me on this?

Kind regards,


Did you check if connection with AVMS is working or not by pinging module from AVMS server ?


Well, I ran the same code again today, and it started working suddenly. I saw messages arriving in AirVantage online console, but then when I turned the device off and on again, it stopped working again. In the AirVantage conline console it keeps saying MQTT Connection, MQTT Connection lost. And this happens like once every 15 seconds.

How is this possible? And how can the connections sometimes suddenly have a payload?

This problem needs a detailed technical analysis. Please contact your Technical support in Sierra Wireless to provide you the solution.

Thanks & Regards,