Help - sstream include error


I am new to Developer Studio and OpenAT development.
I wanted to use sstream, but when I include it in the header, the file is not found and will not build.

Include error: sstream: No such file or directory

I checked the location of sstream file and it is not in the “include” folder.

C:\Program Files (x86)\Sierra Wireless\Developer Studio\tools\armeabigcc\4.4.1\arm-none-eabi\include\

It is located in

C:\Program Files (x86)\Sierra Wireless\Developer Studio\tools\armeabigcc\4.4.1\arm-none-eabi\include\c++\4.4.1

I tried importing it but the other headers are not included automatically.
How can I include sstream and in doing so, it will also automatically include the other headers?


Do you try to include it in a .c file?
is a C++ header, and will be resolved only for .cpp files…

Yes, I did. It is in the main.c file.

I tried:
#include “sstream”

but it can’t locate it because it is in another directory.
I have also tried adding the path:
#include <c++/4.4.1/sstream>
and though it can locate it, the other header files included in sstream is not found also.


My point was that in order to call the C++ compiler, your source code files must use the .cpp extension.
Please note that you’ll to need to start mixing C and C++ in your Open AT app code (using the extern “C” statements, etc…); you can have a look to the adhoc page in the Developer Studio online help (Developer Studio User Guide > Build System > Advanced topics > Adding C++ code to an Open AT application)

I’ll look into this.