Help! MangOH yellow not booting up


My Sierra Wireless WP7702 mangOH yellow device has stopped booting up. When connected to power source (laptop USB) via USB port, only the steady green light LED is on, and stays the same. Earlier it used to turn to yellow and then 3 lights blink one after the other (indicating that the device has booted). But now it is not happening (I had tried to update with another firmware). Can’t even ping to update to another firmware. I don’t know how to use the reset button (I tried pressing it and releasing it as mentioned in the steps, but doesn’t help). Will be grateful for any help!

Thank you!!

there is a TP1_boot pin in SW403 which can kick module to download mode in order to download FW

Can you please guide me how to use this? I can spot this (see image attached alongwith) but don’t know how to operate it. I was taking help from this doc:

Table 3.6 on Page 25
But not sure how to switch the TP1_BOOT on

Thanks for all the help!!

you can see here:

Yes this is the table I was mentioning in my reply. But how to switch it on?

not sure what you are asking here…
you cannot switch SW403?

Yes, I don’t know how to use the switch. Can you please point me to the correct resource? Maybe it is too basic and can’t find anywhere teaching how to operate the switch, to switch on the TP1_BOOT dip of the SW403. Thanks a lot for your help @jyijyi

you can use fingernail or toothstick to switch the 2nd switch to another side

Oh ok looks like there is a thin plastic film on the top. I guess will need to remove this first?

I was able to switch the TP1_BOOT to ON. But now when power on the device, it still doesn’t boot up. What to do next to download FW in this download mode?

if you don’t see any port enumerated in linux or windows, then probably the module is dead

You can try with a good module on this TP1 pin

I can see some ports (Like Sierra wireless DM Port (COM9)) listed in my device manager. Image attached.

But earlier it used to show more entries (an older screenshot of device manager, which shows some entries in network adapters as well Ethlink ECM and Broadband Network adapter, and in Modems also - WWAN Modem). Also there was another port NMEA PORT shown in Ports (COM and LPT) which is not showing now.

the DM port (COM9) is for downloading firmware.
You can run the exe to upgrade FW to it

After that you can switch the TP1 pin to original place and see if it can boot up successfully

How to run this on the DM Port (COM9)? Earlier I had first scp the spk file on the device, and then used the fwupdate command after sshing into the device. But now I can’t do that (can’t ssh into the device). Can you point me to some reference that shows how to follow the steps you mentioned? Thanks a lot!

didn’t you can download exe here?,-d-,1/#sthash.0P6q33TE.dpbs

Yes, but this doesn’t work, that’s why had used the spk method (scp the spk file on the device and then use fwupdate command after ssh on the device).

When I double click this exe file, it shows this screen

The device is connected via USB port and powered on, and I can see Sierra Wireless DM Port (COM9) in Ports in Device Manager

You can extract the exe by 7zip tool
And the use command prompt
fdt2.exe -f xxx.spk

Sure thanks let me try this! Thanks a lot!!

I tried the steps, got this issue:

C:\Users\ravneetsingh\Downloads>cd WP77xx_Release15.1_SIERRA

Volume in drive C is Windows
Volume Serial Number is CA67-DE91

Directory of C:\Users\ravneetsingh\Downloads\WP77xx_Release15.1_SIERRA

12-07-2023 13:53 .
12-07-2023 13:53 …
28-02-2019 11:09 664,056 fdt2.exe
28-02-2019 10:08 1,583,608 GobiApi.dll
29-01-2023 23:20 60,324,403 WP77xx_Release15.1_SIERRA.spk
3 File(s) 62,572,067 bytes
2 Dir(s) 11,156,533,248 bytes free

C:\Users\ravneetsingh\Downloads\WP77xx_Release15.1_SIERRA>fdt2.exe -f WP77xx_Release15.1_SIERRA.spk
FDT version: 1.0.1902.1
Another FDT instance has been running, exit this instance now …
Press Enter to continue …

C:\Users\ravneetsingh\Downloads\WP77xx_Release15.1_SIERRA>fdt2.exe -f WP77xx_Release15.1_SIERRA.spk
FDT version: 1.0.1902.1
Awaiting suitable port or adapter …
Switching to streaming mode …
Downloading images …
Writing image -
Flashing image
Awaiting adapter …
Enabling selective suspend …
Firmware download failed.
Primary error code: 14 - No MBN adapter available.
Secondary error code: 0 - Not applicable.
Device error code: 0x0 - Unknown device error code.

Preexisting images information:
Final images information:



Total time elapsed: 281484 ms.

Images downloaded:
Image ID: 001.049_000
Build ID:
write time: 23078 ms
additional flash time: 16703 ms

Time to reset to application mode: -1 ms.

Press Enter to continue …

Looks like it is not able to find the necessary adapter. Any ideas how can I resolve this?

it is because TP1 pin is in download mode, after firmware download, module reboots, it would still stay in download mode

How about switch the TP1 pin back to original position?
Can it boot up?