Swiflash mangOH wp7702

HI there, I have mangOH Yellow WP7702.
Used custom linux distribution source and generated image with yocto make.

I used swicwe --output /tmp/image.spk --cat yocto_wp77xx.4k.cwe appsboot_rw_wp77xx.cwe

The output just said rebooting. when I ran the swiflash command and rebooted. I do see COM port but my ssh root@ won’t respond. I can not ping the device after rebooting.

Can you help me with identifying what happened here?

Command line output :
[username@fedora ~]$ swiflash -m “wp77xx” -i /home/username/yocto/Legato-Dist-Source-mdm9x06-SWI9X06Y_02.36.07.00/yocto/baseimagev1.spk
Detecting USB of the target
Communicating with the target
Downloading the firmware
Rebooting the module
Rebooting the module
… never ending until I abort with Ctrl + C

Why don’t you download /tmp/image.spk

Do you have the uart console to see what is happening?

What do you mean?

Download it and manually copy on to SD card and re-insert?

You can use fdt2.exe in windows

I am on fedora linux

What is baseimagev1.spk
Can you download the official one

The baseimagev1.spk is my customised image (yocto_wp77xx.4k.cwe + appsboot_rw_wp77xx.cwe I got these .cwe from doing make from yocto)

Can you download the official wp77 fw?

I did… It is official one. My issue is that when I run swiflash command it says rebooting and doesn’t end at all and I can not access the device through ssh or COM port after.

so you mean the module is rebooting and no more USB AT port or USB ECM port for communication?

In mango yellow, there is a pin TP1_BOOT in SW403, changing the status can make module into download mode