Using FDT Tool (Win) to Restore Root File System (Erase USER1 Partition)

Is there a way to erase the user partition for a MangOH Red through a Windows machine? I’m locked out of my MangOH Red because I turned off the root password in favor of SSH login only and now I’m completely locked out.

I tried to use swiflash -m WP77XX -r. I understand that it will not work on a VM, I tried it anyways.

I tried using the IDE, also through a VM. It is using the same command as above, so it also did not work.

I have also tried to use the FDT Tool. I was able to update the firmware, but this did not erase the user partition.

Had the same issue, but found that included with the fdt2.exe tool is factory reset images:

windows\fdt2.exe -f reset\WP77XX\reset.cwe

I think it’s pretty much the same as swiflash -m WP77XX -r but it does wipe the root password for me.

Awesome, thanks martijns! Unfortunately, I’m still in the same place I was earlier. Perhaps I am not using the correct recovery image? I couldn’t find it in the archive that came with the FDT tool, so I downloaded the 'Legato App Developoment Kit (Windows)" and found a recovery image in there.

C:\FDT\fdt2.exe -f C:\FDT\reset\WP77XX\wipe_mntflash_wp76xx.cwe

Firmware download failed.
Primary error code: 77 - Failed in streaming download stage.
Secondary error code: 68 - Received incorrect response.
Device error code: 0x97 - Not allowed.

Please do note that I’m using an FX30S device with the WP77xx, not MangOH Red. I didn’t read that the first time :slight_smile:

I’ve used the download from this link: https://source.sierrawireless.com/resources/airprime/software/swiflash/

Since I’m on Windows, I used the ‘alternate distributions’:

For alternate (non-Ubuntu/Debian) distributions:
1. Download the swiflash tool archive from this link.

Where ‘this link’ points to: http://downloads.sierrawireless.com/tools/swiflash/swiflash.zip

It contains both the reset images as well as FDT2.exe. Perhaps the reset images differ from the ones you’re using, so might be worth a try.

I’m not familiar with the error codes you’re getting, so you might need to wait for an official answer if this doesn’t help.

Thanks martijns, I appreciate the effort. I’m still dead in the water, unfortunately.