GX440 - major bandwidth issues

We have 50+ Sierra GX440 modems on the Verizon network and I noticed they are extremely slow. They are in a private Verizon cloud so I attributed it to that conditions. I am getting less than 1Mb down and almost 1 Mb up on the 4G Verizon network.

I replaced the sim card in a GX440 just to confirm it was the Verizon private cloud network and I discovered that the SIMs used in an Apple on Verizon that received 25Mb down ONLY received 1 Mb down when I placed this sim in the GX440. I tried another GX440 and had the same result…WTF…I then tried another sim from Puppy wireless which got 6Mb on Verizon…in the GX440 it was again less than 1 Mb down!!! I upgraded the code to the latest and it made NO difference.

What is going on with the GX440s? I have 4 bars on the Verizon link and I tried two stubby antennaes instead of the main car antenna we use and it also made no difference.

Verizon tells me the issue is not on their end…This may be the last bunch of Sierras we ever order since these issues are getting out of hand. I should not be having these kind of problems … I have no idea how long this has been going on but I suspect years…our software doesn’t need much bandwidth but that is about to change…along with the Sierras possibly.

Any ideas as to where the issue is? I see nothing unusal in the config and I factory reset it multiple times during each test to verify I had not created this scenario …but this failure is with default config on the box connecting directly to Verizon wireless.

Exactly - thats why switching to Cradle Point makes a whole lot of sense.