GRE Tunneling on V 4.17.0 - new syntax help

We have 40+ MP series routers deployed, all with GRE tunneling back to HQ and all with ALEOS version no higher than V 16.x. I received a newer MP70 that had been upgraded to V 4.17.0 and the GRE tunnel page has changed. In V16, I had “remote address type” which I chose “subnet address” (other choice is “single address” - V17 has “tunnel IP mode” with the choice of “ethernet lan ip” or “custom”. The next field that has me stumped is it used to be “remote address - netmask”, which is now “remote address/subnet list”. Our lan is so the “subnet address” worked as and the “remote address - netmask” was All was fine and worked. I took some guesses and searched the topic as much as I could, but I am not a CIsco wiz nor a network engineer and could not get it the VPN to link. Can someone help me figure out the syntax for these new fields?

Hi @blaineh,

Please refer to the GRE section on pages 221 of the ALEOS 4.17.0 Software Configuration User Guide and page 220 of the ALEOS 4.16.0 Software Configuration User Guide for AirLink MP70 at the following link:

Because the ALEOS 4.16.0 Software Configuration User Guide for AirLink MP70 is no longer available on the source page, I’ve attached the file from my local computer for your reference, hoping it might be helpful.


Thank you @jerdung - In case any non-network-expert like me happens by this post, here are the differences I’ve found in the GRE fields between versions. v4.17 has a different way to enter the network information of the remote site. CIDR notation of the “local” network seems to make this a more secure device than v4.16 and prior. In our scenario, the local network is - I had been over-comparing the two fields between versions. Now that SW support helped me with the correct entries, it seems like a no-brainier. I’ll put up screenshots of the 2 different ways we filled out the GUI to accomplish our GRE VPN back to the mother-ship. If I had just seen this example, it would of helped me to figure it out. Maybe,