GL7500: AT+WMANTSEL=11 + AT&W0 = firmware corruption

I’m trying to configure the GL7500 to only use the primary antenna since we don’t have anything connected to the diversity antenna port. The manual says the setting is stored with the AT&W command, but if I issue that command after changing the setting, the modem seems to become corrupted and must be left powered for several minutes (firmware recovery?) before it becomes responsive again. This doesn’t seem like the expected behavior…

[36] 1572999297.127441 LOG_String: MDM:AT
[36] 1572999297.157226 LOG_String: MDM:OK
[36] 1572999298.087829 LOG_String: MDM:AT+WMANTSEL?
[36] 1572999298.107330 LOG_String: MDM:+WMANTSEL: 00 OK
[36] 1572999298.127655 LOG_String: MDM:AT+COPS?
[36] 1572999298.277343 LOG_String: MDM:+COPS: 0,0,“Rogers Wireless”,7 OK
[36] 1572999298.297729 LOG_String: MDM:AT+COPS=2
[36] 1572999298.707336 LOG_String: MDM:OK
[36] 1572999313.878845 LOG_String: MDM:AT+WMANTSEL=11
[36] 1572999313.908264 LOG_String: MDM:OK
[36] 1572999313.928802 LOG_String: MDM:AT+WMANTSEL?
[36] 1572999313.948272 LOG_String: MDM:+WMANTSEL: 11 OK
[36] 1572999313.968505 LOG_String: MDM:AT&W0
[36] 1572999313.988250 LOG_String: MDM:OK
[36] 1572999314.008605 LOG_String: MDM:AT+FMR
[36] 1572999314.028320 LOG_String: MDM:GL7500.A.2.15.151600.201809201422.x7160_3 OK
[36] 1572999314.048583 LOG_String: MDM:AT+WMSN
[36] 1572999314.068328 LOG_String: MDM:Serial Number TY813185630310 OK
[36] 1572999314.538726 LOG_String: MDM:AT+CFUN=0

[38] 1572999580.043701 LOG_String: MDM:Enable
[38] 1572999584.112579 LOG_String: MDM:AT
[38] 1572999586.272247 LOG_String: MDM:AT
[38] 1572999588.432342 LOG_String: MDM:AT
[38] 1572999590.592468 LOG_String: MDM:AT
[38] 1572999592.752593 LOG_String: MDM:AT
[38] 1572999594.912780 LOG_String: MDM:AT

AT+CFUN=0 is used to turn off module, so if you use this command, module will not return anything. It is not FW corruption.
If you want to reset module, you can use AT+CFUN=1,1
Please file AT user guide as below:

Ah - I left a couple details out. After the “AT+CFUN=0”, I remove power from the modem. Then some time later I turn the power back on (MDM:Enable) and the modem doesn’t respond to AT commands and the green light that normally indicates it powered up just blinks very slowly for several minutes before returning to normal.

Hi bob.doiron,
It seems that modem tried to connect to network but it failed, so modem did not return anything.
This issue can be happened when the network’s strength is very weak, and modem tried to search other network (it takes about 2-3 minutes) . It is not related to WMANTSEL or CFUN command.
Please check APN,band, and CSQ.
If you don’t want to wait 2-3 minutes, you can close UART port and then open it again, you can send command normally.


A. The modem works connects to the network and functions properly.
B. If I disconnect from the network, issue the WMANTSEL command and re-connect, it continues to function properly.
C. If I save the antenna selection and cycle the modem power, the modem becomes responsive for several minutes. When it finally does respond, the antenna selection is no longer saved.

I don’t see how your answer explains that chain of events.

I have just found 1 device that is the same firmware as yours. And I can reproduce this issue. It’s a firmware issue. You can contact Technical support or your distributor to get a support.


1 Like