GL6100 Hangs with AT commands


#1

Hi

I am using the GL6100 Modem with the TCP_Client application, transfering all data to/from the RS232 port (after the application is activated). But, we have seen that sometimes, before application is activated, the unit gives the “ERROR” message to the AT commands (e.g. the AT+wopen=1) and after this happens, it answers with an “ERROR” message to all commands and needs to be rebooted to work again.

In the following line you can see the unit‘s firmware and other information:

“FW”,“FW_SRC_746_8.WMP100x”,“R7.46.0.201108091301.GL6100”,“Sierra Wireless”,2216044,“080911 13:01”,“2f1beedd”,“00020000”

“OAT”,“1.0.0.20130226093858”,“tcp_client Sample”,“MyCompany”,121048,“022613 09:39”,“5d47917a”,“00260000”

-“Developer Studio”,“2.3.0.201212051546-R10684”

-“Open AT Application Framework package”,“2.37.6.201301161050”

-“Open AT OS Package”,“6.37.0.201202060950”

-“Firmware Package”,“7.47.6.201212170952”

-“Internet Library Package”,“5.43.3.201212250709”

“ROM”,“400000”

“RAM”,“1000000”

“DWLNAME”,“GL6100”

I have seen in another topic that to use the GL6100 we need to use Open AT Framework Package 2.3X and not the 2.5X due to memory issues.

How can we prevent it from hanging? Do we need to upgrade to a new firmware? Which one?

Thanks


#2

Is that immediately after a download (AT+WDWL)? This can happen if the unit is still in download (bootloader) mode…


#3

No, the download is complete, and the unit has worked correctly several times, but sometimes it hangs and there is no way to take it out of this status except by rebooting. We’re thinking it might be some character(s) it does not like, or some RF interference, but we don’t understand why it stays in this situation for ever…


#4

So why are you restarting the application?

If you enable extended error info (AT+CMEE=1) & save do you get a more informative ERROR code :question:


#5

at+CMEE is already 1, but we only get the “ERROR” message with no other codes. We are restarting the application because we are in the development stage and are making tests. Is there any problem in activating and deactivating the application (on demand) in field?

Regards


#6

It adds another possible thing to go wrong!

I don’t know if there’s any particular reason not to, or any paticular risk with doing so - but I never stop the app unless I have a specific reason to do so…


#7

When need to do so to check for SMS messages through the RS232 port using AT commands.


#8

Wouldn’t it be better for your application to provide a means to escape to AT Command mode; eg, using the standard ‘+++’ escape sequence…?

It sounds like your application is “taking over” the serial port - are you sure that the application is actually stopped, and it’s not the application that’s saying “ERROR”…?


#9

We also need the socket to be stopped…

We will check again the application and the ERROR to see if we can clarify it more…

Thanks


#10

That could be part of your “escape” handling…


#11

Hiya,

You NEED to be sure that the development environment you are using is building your code against the SAME firmware as is loaded in your modem.

i.e. from your ati9 command, you need to ensure that you are using the Open AT packages that match:

"Open AT OS Package","6.37.0.201202060950"

and

-"Firmware Package","7.47.6.201212170952"

Mixing Open AT packages with different versions of firmware is a sure way to crash your application.

Note that you can install multiple different Open AT packages into the development tool simultaneously, and select the appropriate package for your module when you create your project.

ciao, Dave