GL7600 fails second HTTPS POST request using AT commands

(Posting GL7600 here, eventhough GL7600 datasheet refers to HL series)

As the title states, I’m trying to execute two HTTPS POST requests right after each other using AT commands sent from a datalogger.

The first one succeeds, but the second one ALMOST always fails. After executing the second “AT+KHTTPSPOST" it never responds with “CONNECT” - however the ““AT+KHTTPSHEADER=1” prior to the POST responds correctly with “CONNECT” and I am able to write the header.

I’ve tried multiple things, including calling AT+KHTTPSCLOSE and afterwards AT+KHTTPSCNX=1, also using “AT+KCNXDOWN=1” and “AT+KCNXUP=1” after first successful request, but before trying second HTTP request, but it never opens up the data line with “CONNECT” response. It actually stops responding to AT commands after returning an OK on my “AT+KHTTPSHEADER=1” command

I’ve seen a couple threads discussing this in regards to WIP, but never found a fix while searching.
(E.g. Http failed the second time and Multiple HTTP Requests - every other one fails)

How do I fix this?

I’ve let it run with current settings throughout the night, and something interesting happened.

It was using LTE until around 5AM, whereas it was down for almost an hour, then popped up using 2G and now it runs perfectly on 2G - what could be the cause?


Which firmware are you using?
I can execute two HTTPS POST successfully on FW RHL769x.2.26.180400.201802141030.x7120m_1.

Can you share your steps and AT command log file so I can analyze it?

I have attached the log file for your reference.KHTTPSPOST.txt (14.0 KB)

Thank you Donald,

I got it to work! I’ll mark it solved now