HTTPS connection issue on HL6528RD


I’m trying to establish HTTPS connection to our internal server by using a server authentication. Here below the sequence of AT commands:

AT+KCNXCFG =1,“gprs”,“internet”
AT+KHTTPSGET =1,“server_path”

The certificate is stored by sending a PEM file in binary format via TeraTerm and the result of KCERTSTORE is always OK. Using DER format gives ERROR.
+KHTTPSGET always results with:


If <sec_level> in KHTTPSCFG is set to 1, no error happens and GET request succeeds.
I found a lot of similar issues inside the forum, but cannot actually understand how to fix it.

Please, do you have any suggestion or working example?

Thanks in advance.

Hi @sabinocolonna

To perform HTTPS connection to your internal server by using a server authentication, you need to configure consistent clock to module and store CA.
Which firmware version are you using? Could you help to share full AT logs?

I can perform +KHTTPSGET successfully with my internal server by using a server authentication.
Please find the log file in attachment for your reference.KHTTPSGET.txt (6.9 KB)

Hi @Donald,

Thanks for your reply. Now it is working!
As you stated, we were setting a wrong clock.