FXT009 escape sequence

Hello there,

I have a telemetry software running that uses 2 modems to communicate between the computer and the data logging unit.
It is working fine with 2 GenPro E18 modems but I needed to increase the baudrate to 115200 and my old modems are unable to work at those baudrates.

So I bought 2 Sierra FXT009 modems, I can start the data communication between the 2 modems but the problem comes when I try to stop the communication.
The connection is established with the command ATDT and is normally stopped by sending the escape sequence +++ followed by ATH0.

Now on those FXT009 modems when I send +++ it goes into command mode but nothing more. It becomes then impossible to get any reply from the modem. I can send as many commands as I want to the modem but it is doing nothing.
I have to remove the power supply from the modem to stop the communication.

On the other modems I send +++ and then it reply’s OK and then I send ATH0.
On the new modems I send +++ and I see it goes into command mode but nothing else, no OK, no error or what so ever and it is then impossible to get any reply from the modem without power cycling it.

I am a beginner with modem communication and don’t know a lot about it.

Here is the AT&V output from my old modems:
E1 Q0 V1 X0 &C1 &D0 S0:001 S3:013 S4:010 S5:008 +CBST: 71,0,1 +FCLASS:0
+CRLP: 61,61,48,6 +CR:0 +CRC:0 +CMGF:1 +CSCS:“PCCP437” +CNMI:1,1,0,0,0
+ILRR:0 +IPR:9600 +CMEE:0 +CSMS:0,1,1,1 +CFUN:1 +CREG:0 +CGREG:0
+CLIP:0,2 +CAOC:1 +COPS:0,0 +CSNS:0 +CSSN:0,0 +CSDH:0 +CMUT:0
+IFC:0,0 +ICF:3 %CGAATT:0,1 %CGPPP:3 $AREG:1 $HOSTIF:0
$VGR: 20 $VGT: 8 $VLVL: 4 $VST: 0 $VSELECT: 0
$PADBLK: 512 $PADBS: 08 $PADCMD: 000b $PADDST: “”, 0
$PADFWD: 0d $PADESC: 00 $PADSRC: 0 $PADTO: 50 $UDPAPI: “”, 1720
$MSCLS: 8 %SLEEP: 2 %CPI: 0 %CGREG: 0 $ACKTM: 0, 0, 0
$MDMID: “354115020150148” $MSGLOGEN: 0 $RTCUPD: 0, 0 $PKG: 48-D2
$APIOPT: 0,0,0,0
$EVTIM1: 0, $EVTIM2: 0, $EVTIM3: 0, $EVTIM4: 0
$EVTIM5: 0, $EVTIM6: 0, $EVTIM7: 0, $EVTIM8: 0
$WAKEUP: 0, 0 $NETMON: 0, 0, 0, 0
$IOCFG: 11101111111111111111
$IOGPA: 10011111111100011111
$EVENT: evgp evtyp evcat p1 p2
10A 0 9 2 4
10B 3 19 1 1
11A 0 9 1 1
11B 3 35 524292 0
12A 0 9 5 5
12B 3 35 524292 0

And this is the output from the FXT009:
Q:0 V:1 S0:001 S2:043 S3:013 S4:010 S5:008
+CR:0 +CRC:0 +CMEE:0 +CBST:0,0,1
+SPEAKER:1 +ECHO:0 &C:1 &D:0 %C:0
+IPR:9600 +ICF:3,4 +IFC:0,0

Anyone any idea what the problem could be?


which Firmware version?


You’ll need to use the command ATI9 to get the firmware information details out of your modem.

Ciao, Dave

Hello guys,

Thanks for the replies!

This is the output from the FXT009 modem:
“DWL”,“V08b0j”,"",“Wavecom”,54744,“022410 18:01”,“e9be6255”,“00010000”
“FW”,“FW_SRC_743_6_F3_1.Q2687RDG”,“R7.43.3.201201300737.FXT009”,“Wavecom”,2141296,“013012 07:37”,“daa98365”,“00020000”
“OAT”,"","","",175504,“040110 06:26”,“cbd05ab1”,“00260000”


On the GenPro modem the corresponding command should be:


I hope this can help to identify my problem.



It looks like your modem is running quite an old firmware version (v 7.43).

I suspect that it will be worth while updating the firmware - at least to v 7.47, maybe up to v 7.52. You can get the .dwl download files from the Developer Zone or from your distributor.

Ciao, Dave

Ok maybe that the firmware update could help.

I downloaded R7.52.0_fxt009.dwl from the developer zone but I have no idea how to install it.
I installed the developer studio and DWLWIN but I don’t see how to update the firmware?

Is there somewhere a document that explains step by step how to proceed?



You can do the .dwl update using a serial terminal an the X-Modem transfer protocol.

There’s a description on how to do the update using a .dwl file in the release notes. Have a look here Release_notes/Firmware_7_52.aspx and at the note hereAnswerDetail.aspx?sSessionID=&aid=487

You can also do it using Developer Studio - see the first link above.

ciao, Dave

Ok thanks for the information.

I decided to go forward with the developer studio option as I prefer to work in a GUI.
I managed to connect to the modem in development mode I think as I can open the COM port and I can see the DTR led going green.
When I want to download the .dwl file to the modem to perform the upgrade it gets stuck at the command: Switching in download mode (AT+WDWL)

I also get a warning in the status tab: The detected firmware version (R7.43.3.201201300737) cannot be found in installed packages

Any ideas?


I’ve never done a firmware upgrade via DevStudio - I use TeraTerm and issue the AT commands by hand.

The modem stopping on AT+WDWL sounds normal - it’s waiting for an X-MODEM transfer to start.

The firmware warning sounds like you haven’t got the right Application package installed. Go to the Package Manager perspective (Windows->Open Perspective) and refresh the default Sierra Wireless repository. Then expand the repository, and install the desired application packages (ending with .52).

Then try the firmware upload again once the application package has been installed.

ciao, Dave

Hello everyone,

I tried the proposed procedures but still unable to upgrade my firmware.
In developer studio it blocks when I try to transfer the .dwl file.

I then tried with the XMODEM protocol, I open a session and type AT+WDWL, then the modem replies +WDWL: 0
Is this normal? What are NACK characters supposed to be?

I then try to transfer the .dwl file but it is stuck at 0%.
I cant transfer the .dwl file for some reason but I dont understand why…