FX30S with NTT Docomo SIM account causes reboot loop


We’re installing a FX30S LTE-M Global in Japan using a NTT Docomo data only account. On power up the modem goes into a reboot loop. If the SIM chip is removed, the modem boots up normally.

I’ve looked through the console log (attached)
putty.txt (41.4 KB)
but not sure what is causing the problem. Any help is appreciated! Thanks.


is it because of insuffient power problem?

BTW, I don’t see a FW for docomo:

Not sure about the power. Using a sierra wireless AC power adaptor. Also, if SIM card is removed and modem powered up, I have no issues with bootup.

Using R9.1.1.013 Generic firmware.


how about the followings:

  1. remove sim card
  2. at+cfun=0
  3. insert sim card and reboot

BTW, is it happening to all sim card?

Tried the at+cfun=0 with same results, when SIM is inserted, modem reboots.

We have tried 2 different SIM chips with the same result.

does the latest FW have same result?

You might also try WP77 FW:


WP77XX firmware version R14.1 (Generic) worked. Modem now boots-up normally with SIM card installed. I’m able to register and connect to cell network.

Now I have to rebuild my app with R14.1 firmware. Do you have a link with instructions for building in VSCode? Up to now I have been using Window Developer Studio and I know it’s no longer supported by SierraWireless.


You can see here



We can’t use the wp77xx latest firmware because we are using the FX30S GPIOs which are not supported by the wp77xx latest firmware. So, until new FX30S firmware is released, we are going to have to continue using the current released FX30S firmware.

Having said that, what other troubleshooting options can you give me? Can we disable the watchdog so the modem stops rebooting long enough for us to determine what the problem is?



How about just update the modem image of wp77 r14.1 on top of fx30 r11?



Question, What are the parts I need to include in the custom firmware build to add support for the serial UART1, the modem’s two LEDs(GPIO47 & GPIO48), and GPIO56?

Again, Thanks!


You mean 8 wire uart1???

Btw, have you tried fx30 r11 fw?

Yes, the DB9 serial port on the FX30S modem.

I tried R11 with no success.

The 8 wire UART1 should be ok on wp77 fw r14.1

Btw, does fx30 r11 has reboot issue?

The FX30 R11 does also have the reboot problem.

How about the GPIOs? How do I add support for them in custom firmware build with R14.1?

You need to wait for the release of fx30 fw r14

Hi @eddie435,

Please do not downgrade to R11 once you’ve upgraded to R14. You may experience migration issues when you upgrade back to R14 in the future.

R14.1 for the FX30 is scheduled to be released towards the end of July.


Thanks for your help!! Very appreciated!



We currently have an ongoing project that we need these modems to work on. The end of July is to far out to have our customers wait, plus we never identified what was making the modems reboot themselves. What if the new firmware at the end of July does the same thing?

I would like to keep troubleshooting the modems with the FX30 R11 firmware to find the problem. Any ideas on what I can do to find the cause are greatly appreciated!

Currently since the modems are in a reboot loop, I can’t get in to it to diagnose. Any thoughts on what I can do to at least look at what is making the modem fail and reboot.




Hi @eddie435,
From the logs, the modem is crashing.

Could you clarify which carrier image you’re installing? Make sure you use the Generic GCF image.

There seems to be an issue with the modem firmware image on Docomo with your SIM. Would it be possible to try a SIM for a different carrier in Japan?

As far as I know, there shouldn’t be an issue on Docomo running R9.1 and R11. If you have to use the Docomo SIM, could you try the Sierra carrier image?

Is the issue occurring on all your units?

Could you please post the output of: