[Fx30] Modem restart when connecting the USB to Windows10

Hello,

I observe a reset of the modem (radio turning off) when I connect the Fx30 to a Windows10 PC.
I would like to avoid the PC connection interfering with Fx30 connection state. I only need the ECM and DIAG on the USB.

It is reproducible 100%. I tried it on a clean Fx30 out of the box.
It is the same on the firmware R14 or on my customized firmware.

Firmware: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Bootloader: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
priIdPn: 9906645
priIdRev: 01.02
skuId: 1103214

In an attempt to remove this problem, I have reduced the USB composition from its default value 0008011D (diag,nmea,modem,at,rmnet0,ecm) to 00080101 (diag,rmnet0,ecm) using the AT command USBCOMP.
With this configuration, Windows contines to see a DM port coming from the Fx30 and continues to reset the modem.

The AT command returns an error when I try to remove “rmnet” from the USB composition.
Could you tell me how stopping the Fx30 from receiving modem controls from the PC?

Remark, I am not searching a solution on the Windows side, as I have many users connecting to the Fx30 with their PCs, I would prefer finding a solution on the Fx30 side.

Regards, Christian.

Hi,
Have you tried to install drivers for FX30?
https://source.sierrawireless.com/resources/legato/drivers-for-wp-series-modules---build-4581/#sthash.X0Bx5Qy1.dpbs
Does the issue happen with Linux?

Thanks,

Hello Jerdung,

I was up to now using the drivers GenericDriverSetup V8.10.4836.0002.
I updated with the driver version you pointed (which is a bit older), after reboot of my PC, the behaviour is the same… immediate reboot of the modem (power LED turning RED) when I connect the USB.

NO, the issue does not happen on Linux.
It is not happening neither on Windows7. Only on Windows10… unfortunately it is what most of us are using.

Regards, Christian.

Hi @CGuyot,

As the issue does not happen on Win7 and Linux so it’s likely that the problem is not caused by the FX30. I also tried my FX30 with several PCs and laptops running Windows 10 but don’t see this issue. You may need to check if your PC is running latest updates. Mine is running Win10 version 1909 with latest updates.

Hello Cherokee,

My PC is running Win10 Pro v1903 with all updates installed (it seems that Windows has stopped pushing the v1909 for some reasons). I have the same behaviour on several PCs (some with rev 1909).

Let me describe what I see:

Initial condition: the modem is attached on a GSM network (power LED is amber).
I connect the USB cable to my PC.
After 3 to 4 seconds the power LED turns red. The “cm radio” command reports that the radio is OFF.

I previously reported a modem reset… this may be a wrong interpretation… it may just turn the radio OFF.

Thanks to check this manipulation on your side.
Regards, Christian.

Maybe similar issue with Win10 1903?

Hello Iotam,

Thanks for the link but my situation looks different as it is not only the case of the connection looking OFF from windows. The Fx30 radio is really going OFF as reported by the “cm radio” command.
When I have a data connection ongoing (exchange of IP data between the Fx30 and internet), it is disconnected.

Regards, Christian.