[fx30] Bricked after AT!RMARESET=OEM (USB device not found)


I recently tried to perform a full reset of the FX30, to revert to original setting, using AT!RMARESET=OEM. This command seemed to execute fine, replying OK.
However, after reboot, I’m not able to connect to FX30 via USB anymore. It doesn’t apear in windows péripheral manager (no unknon device, and no new COM port when I plug it in). On linux, using dmesg I can’t find any FX30 related messages either.

I tried to perform a hardware reset using the reset button (hold it pressed for 10 seconds at startup). At boot, the device power consumption is between 70 and 100mA, and goes down to 50mA after a few seconds (voltage=5V), so I guess something is still running, at least at startup.

Is there any way to recover it ?

It seems I need to locate TP1 pin, to flash the WP8548 used in FX30 (pin 47), to start in bootloader mode, which should bring USB DM port up, allowing me to use swiflash utility : source.sierrawireless.com/resou … /swiflash/
However, I didn’t find any reference to this pin on FX30 datasheet. There is many test point under the PCB, any chance one of them is connected to TP1 ?

Hi SL8082,

Please find the attached image. The test point you need is highlighted in red. It’s on the bottom side of the board, near the antenna connector. If you point the antennas to the left, it will be near the top left corner. Please solder a wire to this test point and short it to ground on power up until the DM port is present, then release it.

Then you can use swiflash to update the firmware.


Hi Chris,

Thanks for your picture, that’s exactly what I needed. I managed to boot in bootloader mode, then to flash a firmware.
I used WP8548 firmware, it seems newer than FX30 one, and allowed me to flash using exe file, which was faster. Not sure if there is some features specific to FX30, but I still can flash another firmware later. I only need AT command right now, it works as expected.

I did try to use AT!RMARESET again, it works fine. I guess I just powered down the device too early.

Just for fun, do you know if the other testpoints are documented somewhere ?


Hi SL8082,
The stock WP image will run, but you’ll lose the FX30 features, including the FX30 specific AT commands.

The test points aren’t documented at this time, but if you need something specific, let me know and I’ll try to help out.