FX100 Modem Problems


I have 2 new AirLink FX100 HSPA+ Programmable Modems I’ve begun to evaluate them and have run into a few problems.

Both modems have firmware version R7.50.0.A2.201302191346.FX100, as obtained using the AT+CGMR command.

Problem #1: After waiting the normal 15 seconds for initialization the flash LED lights up, indicating the modem is powered on. With a valid SIM present and inserted properly, and a sufficient RF signal present, the LED turns off after a few seconds, which to me indicates that the modem sees the signal. However, after this the LED stays turned off, and does not flash on and off periodically like it should. I’ve checked using the AT+WHCNF? command at it returns +WHCNF: 1,1,0, which indicates that the flash LED is enabled. So, how can I get the LED to flash on and off like it should? Has anyone else experienced this?

Also, I know that the RF signal is present as I can then issue an AT+CREG=2 command, and the modem will register on the network as expected. However, the LED remains off. I’ve also verified I can make calls between the two FX100 modems using 2G SIMs and 3G USIMs. This behavior is the same on both of the modems I have. I’ve used the prior generation Sierra Wireless FXT003 Modems and others and the LEDs always begin flashing on and off when a valid RF signal from the cellular network is detected. Why are the FX100 modems different?

Problem #2: I telnet into a FX100 modem over a standard RS232 connection to issue AT commands as needed. This works fine. However, after a period of about 10 minutes of inactivity (i.e. no AT commands have been issued), the modem serial connection shuts down. I then have reconnect via telnet again to use the modem. I understand that the modem has a new Serial Connection Shut Down feature, but I do not have it enabled. Why is this happening? Is there any way to configure the modem not to shut down like this? The modems I’ve used in the past never auto disconnect the serial connection, and I am using the same serial cable connection as I’ve used successfully with other Sierra Wireless FXT003 modems before.

Problem #3: The older Sierra Wireless FXT003 modems I have automatically register on the network upon detection of a valid RF signal from the cellular network. However, the FX100 modem does not automatically register. I have to issue an AT+CREG=2 command to manually force the modem to register on the network. Has the auto-register feature been disable with newer modems or firmware like this? Is there any way I can configure the FX100 modem to automatically register (like a cell phone does) when it sees a valid signal?

I look forward to anyone’s 2 cents on any of these problems. Thank you!

I have the answer to Problem #3 as received from another user. Here it is for others that might want to know.

To get a modem to auto-register, issue an AT+CREG=2 command to enable registration and location information unsolicted result code. Then, issue an AT&W command so this parameter is stored into EEPROM. Why didn’t I think of this? Doh! After this, if the modem is either powered off and on, or soft reset, it will automatically re-register. If you don’t want location information unsolicited result codes to appear when this registration takes place, use the AT+CREG=1 comand instead, and issue AT&W to save it.

The FW that is in your modem is old and for example the flash LED not working is a known bug. I suggest you update the FW to the latest official:

There should also be a 7.53 coming soon with more bug fixes and also some new features like AVMS.


Thank you for the firmware upgrade answer. Another user also informed me about this, so I will upgrade my FX100 firmware from version 7.50 to 7.52 and hopefully this will fix this bug.

I will let you and others know if this works.

I am surprised however that Sierra Wireless released their new FX100 modems with Firmware 7.50 in them with this type of significant bug present. They also didn’t document that these modems take 15 seconds to initialize before the LED even turns on to begin with upon first powering them on. Oh well…


I have solved all 3 problems.

Problem #1 was solved by upgrading my FX100 modem firmware from version 7.50 to version 7.52.

Problem #2 was solved by disabling a default timeout setting of 600 seconds accidentally used on the serial ports of the Console Server where the modems were connected.

Problem #3 was solved by simply saving the AT+CREG setting I choose to the EEPROM using AT&W.