Fx100 GPS

I’m unable to get a GPS fix with 2 different Fx100 modems with the GPS LocationServices Package. The commands I’m using are:

The response back from the modem seems correct, but I never get a fix. The antenna is an active antenna the same as was used on aFxt009 Has anyone been able to get a fix using GPS Location Services?


What’s the version of FW and GPS library you are using?
Also, do you have power supply to the active antenna?

Do you have clear sky during test? and does GPS fix come if you wait longer?


To enable the active antenna, you should set the GPIO44.


Here’s everything from the ATI9 command:
“DWL”," SWI6200T_01.02.03.06BT R2521 CNSZXD00000145 2013/02/07 17:07:24","",“Sierra Wireless”,0,"",“00000000”,“00000000”
“FW”,“FW_750_20_A2_3.FX8Fx”,“R7.50.0.A2.201302191346.FX100”,“Sierra Wireless”,1658520,“021913 13:46”,“f6eaa2f2”,“10002020”
“MODEM 3G+”,“Revision: SWI6200T_01.02.03.06AP R2521 CNSZXD00000145 2013/02/07 17:07:24”
“OAT”,“v1.20A2.20130219180830”,“Extended AT Application”,“Sierra Wireless”,300680,“021913 18:08”,“f8e417f7”,“10700000”
-“Developer Studio”,“”
-“Open AT OS Package”,“6.50.0.A2.201302061510”
-“Firmware Package”,“7.50.0.A2.201301311052”
-“Internet Library Package”,“5.53.0.A1.201212051411”
-“Location Library Package”,“”
-“Security Library Package”,“”
-“eCall-InBandModem Library Package”,“”
-“ExtendedATApplication Library Package”,“1.20.0.A2.201302191807”

I figured the active antenna needed power. I configured the GPIO using this command:
Then tried both a high:
and low:

The modem was left in the open skiy for over 20 minutes with GPIO44 high and low. I’m still not seeing any unsolicited NMEA sentences.

I would suspect to see unsolicited responses even without a fix, correct??

Could there be a hardware configuration +WHCNF I’m missing?


Try this:


Those are exactly the commands I have been doing. I see the correct responses:
but I never see this response “+GPSEVPOS: 0” that others with a Q2698 module have seen.
I also never see any NMEA sentences. If I check TTFF with this command AT+GPSTTFF?, it always returns -30,-30 (indcating no fix).

I’ve also tried two different Fx100’s. I know that Fx100’s are very new. Could this be a hardware issue with the device? I know that Q2698 modules work but does anyone actually have an Fx100 that the location services work correctly? I’ve never experienced troubles like this with various Fxt series modems and IESM cards.

Similar problem here : [url]https://forum.sierrawireless.com/t/q2698-gps-fix-problem/6651/1]


His problem appears to be the active antenna. My problem is I never get a fix but I also never see any NMEA sentences whatsoever.

I believe that this feature is locked in the software of your device. This happened to me on my FX100. The GPS did work if I used the Watcher software but it did not work if I used the extended at commands. There is a command to unlock this feature but you should contact your distributor to get the code.

Thanks krima919 ! I had the same problem not getting NMEA output even though all the other commands made it look like GPS was enabled properly on the device. I found out that GPS was not properly enabled at the factory and my FAE had to send me some specific AT!OPENLOCK and SETLOCK commands to fix it. It worked right away after doing this.