Frequency of 'Check For Updates'

Is it really necessary for M2MStudio to ‘Check For Updates’ every single time it starts?! :angry:

It seems to take ages, and M2MStudio is sluggish while it’s going on - and, apparently, certain things are not safe while it’s happening; eg, https://forum.sierrawireless.com/t/m2ms-1-1-1-check-for-updates-fails/3915/9

Can this be configured to happen, say, just once per week?

Obviously it can be configured! :wink:
Go to Window > Preferences > Install/Update > Automatic Updates
It’s configured by default to check on every launch, but you can change that…

With Eclipse, nothing is obvious!

:laughing:

BTW: don’t you need to change your avatar - isn’t “Wavecom” a forbidden word now?

in the same category…
why does it keep whining for an internet connection when my pc isn’t connected to the internet?

Presumably because it wants to “check for updates” :unamused:

As I do sometimes have to work “on-site” or “in the field” without an internet connection I find it really annoying when applications insist on trying to access the internet instead of just getting on with their work! :angry:

Since a great deal of so-called “M2M” work is about remote monitoring & control, I think this should be an expected situation with M2MStudio - so there should be some option like, “don’t attempt to check for updates (or do any other internet-related things) when no internet connection is available”

You’re right, but maybe you know how long it takes to propagate branding updates everywhere :wink:

That question remains unanswered: https://forum.sierrawireless.com/t/is-wavecom-now-officially-dead/4176/1

Yes, I changed it to “Every Monday at 1:00 AM”, clicked ‘Apply’, then clicked ‘OK’

Then I repeated Window > Preferences > Install/Update > Automatic Updates - and verified that it was still as I set it.

But when I restart M2MStudio, it puts itself back to check on every launch!

:angry: :angry:

:angry:

Yes, I changed it to “Every Monday at 1:00 AM”, clicked ‘Apply’, then clicked ‘OK’

Then I repeated Window > Preferences > Install/Update > Automatic Updates - and verified that it was still as I set it.

But when I restart M2MStudio, it puts itself back to check on every launch!

:angry: :angry:

:angry:

Can’t reproduce this behaviour here, with 1.1.1, and even by switching between several workspaces (the update settings are common to all workspaces).
Maybe could you have a look to the p2\org.eclipse.equinox.p2.engine\profileRegistry\M2StudioProfile.profile.data.settings\org.eclipse.equinox.p2.ui.sdk.scheduler.prefs file (relative to your M2M Studio install)?
Eclipse saves automatic updates settings in this file…

E.g. for every monday at 8 a.m.

#Mon Feb 22 08:31:19 CET 2010
migrated34Prefs=true
hour=8\:00 AM
day=Every Monday
enabled=true
eclipse.preferences.version=1
autoUpdateInit=true
schedule=on-schedule