Firmware Upgrade FS10 DwlWin, Fatal timeout


I want to make a firmware upgrade a Fastrack Supreme 10 using DwlWin.

I have the following firmware,

663_09gg.FSU001 1955080 080207 16:01


and i want to upgrade to “R74_00-cus-q26-01.wpk”.

My procedure is:
1 - With the modem power OFF, i connect the boot pin (pin 3), from the 15 pin connector to a 10k resistor, that is connect to the ground.
2 - In the download tab of DwlWin, i check “R74_00-cus-q26-01.wpk” firmware, and click start with a 115200 baudrate.
3 - I power ON the modem, and the status bar starts to fill.

Then i receive,

Fatal timeout error: The target is not responding

I tried to pull out the boot pin while status bar filling, and i got same error.

Anyone can help me???

Thanks in advance


Same problem, no solution found here. Fatal for the modem?

Too much time lost with Sierra Wireless. I am now working with an other modem. This one has a JTAG interface.

Hi mi,

what’s the current FW and target FW you are going to upgrade?

Have you check this post?


Hello lotam,
My modem is a Fastrack Xtend fxt003. My firmware was R7.44.
6 months ago I used successfully this recovery sequence to get my modem work again after a “software crash”. I made the special cable, good settings and DWLWin.
But this time I have the progress bar going on and when finished the message:
“Fatal timeout error: the target is no longer responding”
I would like to put again the R7.44 or another newer firmware release.
My problem began when I did the upgrade of Developer Studio. I had problems with the USB driver.
The USB port was for programming and the RS232 port exchanging data with a flight computer.
My program was doing a good job. Stopped … shot down in flight!
I am now writing the same program in an other modem. But it has not the USB, so my work is difficult.

Do you know if it is possible to use JTAG programming? I have a segger (SAM-ICE) probe.

Thanks for the help!

Modem still alive!
My problem is fixed; I have made several things:
-Remove every remaining piece of the Sierra Wireless USB driver from my Windows XP.
-Open the modem case, to see if there is a JTAG connector.
-Plug the USB and open HyperTerminal with COM6 (suddently seen in “properties”).
I had then a response on AT command.
Then DwlWin (with COM6) to upgrade with the R7.46.
Then upgrade Developer Studio with 2.11
Everything works fine now…
What was wrong? Bad contact in the modem? Bad USB driver?
The RS232 link was out of order, may be because it is in “data mode” at the beginning of my program.