Escaping a Traces flood


#1

Well, sure, there is a warning (that nobody reads… thank you internet ads…) but it is still possible to select ALL tracelevels.

But, then the flooding comes… Well, I could live with that.

But how the heck am I supposed to stop the flood… Because of it M2M Studio fails to retreive the list of levels…


#2

Use TMT?


#3

TMT?

An external tool? Available from?


#4

TMT = Target Monitoring Tool; It’s the Wavecom tool that was provided before M2MStudio came along.

M2MStudio’s Target Management perspective is supposed to replace it - but, unfortunately, it doesn’t wok.

If you can find an old (pre-M2MStudio) SDK, it’ll be in there as part of the “Development Toolkit”


#5

or reset the module?
you don’t need to retrieve all the traces to set the trace levels you want to see.


#6

Resetting the module did nothing at all… (By resetting I inlcude, powercycle, resetbutton on the devkit, even at&f)

And the m2m target perspective cannot modify traces before it has started to recieve traces… But when it is flooded it cannot modify traces… Catch 22…

But after some digging I found an pre m2m version of the openat sdk that included the TMT software… Then it only took a few tries to disable enough to stop the flood.

THANKS!


#7

I see you’ve solved your problem already, but another solution might have been to stop the application by sending “AT+WOPEN=0” from the remote shell.

if a trace flood is going on, the module doesn’t respond with OK, but you will see +WIND indications showing that the command completed successfully.
(you might need to repeat the command a few times)


#8

This should work only if the trace flood comes from the application itself, not if many trace levels are enabled on the Firmware elements.
However, in new Target Management, we’ll take care of adding a kind of emergency button allowing to disable all traces in one click, to get out of such a trap…