No TRACE messages


#1

Hi all,

I’m busy getting accustomed to M2M studio and I’m having some trouble with TRACE messages in the “Hello World” demo.

[Target]_ARM_ELF_GCC_Debug is set as “Active”

Project is built as [Target]_ARM_ELF_GCC_Debug.

In Target Management Perspective I then download the built .dwl file to the Q2687.

I can see the “Hello World” string from adl_atSendResponse in the Remote Shell but no TRACE messages.

I’m sure I’m just missing something simple.

Any suggestions?

Thanks!

Stefan


#2

Hiya,

Try running your app from the ‘Run Configuration’ button in the editor perspective, rather than downloading it from the TMT perspective.

Also, in the TMT perspective, you have to (a) explicitly open the remote traces view, and (b) reconnect to the device (look for a button with a red circle on it) after each download or reboot of the target device.

Hope this helps.

ciao, Dave


#3

Thank you for the help Dave! :slight_smile:

Problem solved.


#4

(I just love it when people go to the trouble of posting “thanks” without saying what actually worked… :confused: )

Hi all,
I seem to have exactly the same problem described above. I’m a newb, and I’ve built the Hello_Word demo under the debug configuration. I also made a run config using all the defaults and ran it on my target - it works fine, and I get messages in my target shell.

But I don’t get any traces. There is a trace output in the source code, and I’ve tried turning the traces on and off but I can’t see any traces? There’s something pretty obvious I’m missing here…

regards,
Richard


#5

OK, figured out how to get the traces running myself so I’ll post it for anyone else having this problem as it’s not obvious and certainly not well documented here or elsewhere.

“Remote Traces Configuration” button in the traces view -> select/check all the levels which apply to your program. I have no idea what the different “Flows” are, I just checked them all - I would assume I needed at least ADL.
Which levels apply? - the tracelevel is the first parameter in the TRACE macro, so look at your code.


#6

Note that the Target Management perspective of M2MStudio is acknowledged to be broken, and is having a “major refactoring” - which is not due for release any time soon.
Therefore I never use this part of M2MStudio - but stick to the old Target Monitoring Tool (TMT).

The ADL User Guide says the following about the trace “flows” (or “elements”):

I don’t know if the one about “tasks” is actually supposed to be true in M2MStudio, but in TMT it is just “ADL” (or “CUS4” in earlier versions)

In true Wavecom fashion, there is not actually anything called “Application Initialization service” - I think they mean, “Application Entry Points Interface”

Also note that ADL itself uses 17 of the Traces levels - which is entirely undocumented:
viewtopic.php?f=23&t=1422&start=0&hilit=undocumented+trace
:angry: