Error while Target Build with Open AT1.02.03 IDE


#1

Dear Members,

I am using Open AT1.02.03 IDE.

I am using Q24Plus as target.

I am not getting any error while RTE build.

But when i use target/actual build i am getting errors as below.

appli.c:66:17: error: wip.h: No such file or directory
appli.c:67:21: error: wip_ftp.h: No such file or directory
appli.c:68:21: error: wip_net.h: No such file or directory
appli.c:69:24: error: wip_bearer.h: No such file or directory

I have wip directory included in C:\OPENAT.
Also i included the WIP library when i make project setup.
But still i am getting errors.

Please suggest what is the problem?


#2

Your include paths are not properly set-up :question:

So, although the files may exist on your hard drive, the tools don’t know where to find them!


#3

I have the following path settings done in Opent AT IDE settings as below.

Open AT OS path: C:\OpenAT\OS\3.13.02

Open AT Firmware Path: C:\OpenAT\Firmware\657c

Plug-ins root path: C:\OpenAT\Plug-ins

GCC(ARM) path : C:\OpenAT\IDE\GCC\4.0.1.0

ADS/RVDS path :

MINGW path: C:\OpenAT\IDE\MINGW\3.8.0.0

Eclipse IDE path: C:\OpenAT\IDE\Eclipse\3.1.2

Is anything wrong in this settings.?


#4

Can you tell me please where i can set-up the paths


#5

I Reinstalled everything (SDK). Again the same problem. But working in RTE mode
I tried with all possible ways.

Please help. :frowning:


#6

Problem solved.

I opened project wizard and selected some old project( which already made target build successfully) then i edited only project path and project name with new project name and path. The new project created is working properly both in RTE and Target build.

This step i done only one time for my problem i was getting.

Here onwards i am able to create new projects without editing by selecting old one.

Regards