Error when applying radio firmware update on RV50

That was it.

Singing and dancing now playing the banjo.

Thank you Jonathan.

I just ran into this issue for the past month. It is very puzzling and disturbing. Sierra Wireless has a problem with their firmware and they do not appear to be addressing this. This problem did not show up until I upgraded all of my modems to the last firmware version, 4.16.0 build 021. The results have been hard to identify and the messages I see in the logs are consistent with one another, however, I cannot get out of this trap without doing a factory reset. I have over 80 of these cellular modems in service and they all occasionally, lock up on the LAN side. I can still remote into them; however, I can’t do anything to correct this. We have had to send a local person out the the remote stations and do a cold boot. This is a significant burden. Additionally, the error message that shows in the logs involves ALMS and Firmware Over The Air update FOTA. At this point, I now have to find a replacement for these now unreliable cellular modems from another supplier who will support their products.

We were very happy with these modems; however, now that they have reached end of sale and eventually, end of life, I expect Sierra Wireless will expect me to purchase ALMS for my 80 plus end of sale modems and then purchase new units from an unreliable supplier. I would rather replace all Sierra Wireless modems and give another supplier a chance to show that they will support their products. I expect nothing from this company except attempts to collect more revenue to maintain a dyeing product offering. This is not good business.

I finally fixed this annoying problem. I have seen it on a few of the many RV50 modems I have updated. Many upgrade fine, some do not. The problem appears to be something to do with the naming of firmware.

If I apply the MC7354_05.05.58.05_VZW_005.032_000.iso file which is part of the more recent RV50 ALEOS package’s download links, I end up with no complaints during the firmware flashing, but a small percentage of the modems end up in a state where their ‘Network’ LED is flashing yellow and red.

If, however, I download tarball from and extract the MC7354_05.05.58.05_VERIZON_005.032_000.iso file from that, I can now flash the firmware without the error message. I do get a warning about changing the network operator from VERIZON to VZW which I acknowledge and apply.

I get a very long period of chasing green LEDS (approximately 2-3 minutes), but the modem does come up and is operational.

I have encountered the same problem. I finally got it to work.

  1. If you update the firmware to 4.16, it fails to copy the three default radio card firmware files and labels them incorrectly. If you try to fix the problem by upgrading the radio firmware, it fails because the radio firmware is expecting to see a default firmware file to check the new version against; however, the default entries in the modem has the wrong name.
  2. If you try to upgrade the modem firmware, it will work; however, it still installs the correct file with the wrong name.
  3. Also, as a cyber security fix, you can’t downgrade the firmware to an older version remotely.

I tried a back door approach: Since the modem can hold up to 8 default radio firmware versions, I tried to just add the correct version so that I could just select the correct version. When I did this, it added the new version, however, it recognized that it was for my Verizon radio card, and chose to overwrite the incorrectly named file with the proper identifier and it worked.

I tried this on 6 units so far and they all worked. I am still waiting for Sierra Wireless to respond to my original request from 6 days ago and if they ever contact me, I will ask them to approve what I did.

1 Like

:100: Seems to be the best way. Thank you for your post!