Error C:\WINDOWS\system32\cmd.exe in VS05


#1

Hey everyone

New installation of VS2005 along with openAT 3.16 is not working.
It is a new computer, but until now I’ve this same configuration on another/older computer, working just fine.
Windows XP professional is running on the new one, but home edition on the older one.

I have Visual C++ 6.0 installed as well, and that is OK, I can build the projects there.

When I build my applications or samples (Hello world) in VS05 it doesn’t complete and presents this error:
Error 7 Error result 1 returned from ‘C:\WINDOWS\system32\cmd.exe’. Project

The following is part of the build output:

1>make: uname: Command not found
1>! var ikke ventet på dette tidspunkt.
1>make: #---------------------------------------: Command not found
1>make: *** […/out/gcc_Hello_World.dep] Error 127
1>/cygdrive/C/OpenAT/IDE/IDE/1.02.03/bin/wmmake: line 1: basename: command not found
1>/cygdrive/C/OpenAT/IDE/IDE/1.02.03/bin/wmmake: line 448: cp: command not found
1>Done.
1>/cygdrive/C/OpenAT/IDE/IDE/1.02.03/bin/wmmake: line 1: basename: command not found
1>[ error #1] Build error.
1>umount: /: No such file or directory
1>umount: /usr/bin: No such file or directory
1>Project : error PRJ0002 : Error result 1 returned from ‘C:\WINDOWS\system32\cmd.exe’.
1>Build log was saved at “file://d:\Work\Projects_OpenAT\Samples\HelloWorld_VS\arm\out\BuildLog.htm”
1>Hello_World - 1 error(s), 1 warning(s)
========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Does it make sense to anyone? There are too many “not found”, “no such file” events there… so lack of configuration of any kind.
I can’t recall this error message when I tried out with VS05 on my old computer, first time. I haven’t re-installed VS05 neither…
I’ve tried to compare System paths on both computers, but not successfully being able to find anything useful…

Regards
palsson


#2

Hey there

Problem solved by installing Microsoft XML service, MSXML 4.0 SP2.
I had MSXML 6.0 but neede obviously the 4.0 package.

…Well that was just a lucky strike. This is not the reason, sorry about that :slight_smile:
I don’t know if anyone else has experienced this, but when building the project in VS05 you have to make sure that no parallel build processes are allowed.
This can be configured in Tools->Opions->Projects and Solutions->Build and Run and here make sure that maximum numer of parallel builds is 1.

Regards
palsson