Enabling +CGEREP Command: Packet Domain Event Reporting

Hi, I m working on the HL7812.5.4.10 modem. So I am wondering how to get/enable Packet Domain Event Reporting +CGEV UNSOLICITED messages.

I can see I have a +CEREG: 5, +CREG: 5 and a valid pdp context when I run +CGCONTRDP.
But I still can’t see these cgev messages.

Thanks for your help.

how about trying like this?

(10:43:50:176) Rcv COM60 [<CR><LF>OK<CR><LF>]  <3000 @108 ms 
(10:43:50:382) Snd COM60 [AT<CR><LF>]
(10:43:50:488) Rcv COM60 [<CR><LF>OK<CR><LF>]  <3000 @102 ms 
(10:43:50:694) Snd COM60 [AT+CGEREP=2<CR>]
(10:43:51:003) Rcv COM60 [<CR><LF>OK<CR><LF>]  <2000 @304 ms 
(10:43:51:209) Snd COM60 [AT+CGATT=1<CR>]
(10:43:51:317) Rcv COM60 [<CR><LF>OK<CR><LF>]  <10000 @101 ms 
(10:44:01:548) Snd COM60 [AT+CGATT?<CR>]
(10:44:01:687) Rcv COM60 [<CR><LF>+CGATT: 1<CR><LF>] 
(10:44:01:709) Rcv COM60 [<CR><LF>OK<CR><LF>]  <8000 @140 ms 
(10:44:01:932) Snd COM60 [AT+CGATT=0<CR>]
(10:44:02:068) Rcv COM60 [<CR><LF>OK<CR><LF>] 
(10:44:02:092) Rcv COM60 [<CR><LF>+CGEV: ME DETACH<CR><LF>]  <20000 @140 ms

thanks for your quick reply @jyijyi . Your at cmd sqeunces worked for me but Now I have more questions :slight_smile: if you dont mind.


I checked all at cmds’ default values, which you shared in your comment before running them.
I had

+CGEREP: 2,0

and just wanted to run AT+CGATT=0 and expected to have cgev but I didn’t. I was wondering why I do need to set the same values again to have cgev.

See here

as seen here I started getting cgev values after setting AT+CGEREP=2 even though it is equal to 2.

May I ask how you got this information to have cgev? from the at cmd reference guide? I am using HL78xx - AT Command Reference Guide - Rev19.pdf and didn’t see this sequence of at command I need to run to have cgev anywhere in that.

Thank you,

probably you need to add this command as init script in every power on