EM9191 NAS & RRC Log


I’m using EM9191 module for development, and I’m currently running into this problem while performing product certification,
I need to provide NAS & RRC status logs for certification, but I use MBPL and found that it is different from the usage of the previous generation,
I use the previous generation module with EM7430, and use the logging-DM-dmcapture.sh in SLQS to do the logging, filters use MC7xxx.sqf
After the module is connected to the base station, the captured log files are recorded, and the log files are saved as IST files with QCAT, and then the NAS & RRC logs are read by QXDM.

At present, I found that MBPL is different from previous SLQS with EM9191, there is no Filter folder, no SQF file, and no dmcapture program.
Please help me to solve the problem, I will be very grateful, thank you so much!

you can download the MBPL_Tools_R30_ENG6.bin.tar and use this filter
Default.cfg (3.9 KB)


Yes, I’m using it, but I didn’t find any files about the filter

you can use my default.cfg attached above

Oh, sorry I didn’t notice you had an attachment, I’ll try!
thank you so much !

Sorry, is the default.cfg available for 3G, 4G and 5G?

never used for 3G, but it should support LTE and 5G

Okay, I will try to see in these three connection modes,
and will ask again if I have any questions,
thank you very much!

I have a problem, when I save the logs, it will open ttyUSB0,
but if I want to save the logs from NAS & RRC,
I need to enter the AT command into ttyUSB0 while saving the logs,
but the program is already occupying ttyUSB0,
what can I do to enter AT command during saving LOG and make it save?

it should open the port /dev/ttyUSB1 for DM logging

I forgot to read the DM port, it looks like it’s working now, thanks!

Sorry, I have one more question,
after entering


After another window finishes typing the command to capture LOG,
The AT command window will start to automatically enter repeated commands,

Do you know how to turn off its auto-repeat?

what do you mean by “start to automatically enter repeated commands”
never see such thing before…

Hmm… If there is this situation,
I have previously entered "AT!ENTERCND=“A710”,
then it will keep typing this every few seconds automatically.

It seems to happen only after the log is captured.

who is entering this? - Tera Term VT 2023-03-06 17-53-05.zip (538.6 KB)

I recorded this situation, please check the attached video…
It will keep typing automatically, I can see what I’ve typed if I have typed

have you enabled ATE1 to see what command is entered? (or you can enable local echo in tera term)
It seems some modem function is using the modem port.
(or are you running some macro script in tera term?)

You can try in linux and see if there is same issue.

I have tried using ATE1 and ATE0, but it doesn’t seem to work.
I also used Putty for confirmation, but still have the same situation,
What I can confirm now is that Cellular will always have this condition if it is activated.

[Expert@Gateway-ID-7FB3C705]# uname -a
Linux Gateway-ID-7FB3C705 4.14.76-release-1.3.0 #1 SMP Mon Nov 7 23:24:08 IST 2022 aarch64 arm GNU/Linux

I never see such issue before.
You might need to install some serial port spy to monitor what command has been sent to AT commad port.
e.g. in linux, you can use:

BTW, are you using windows (WIN11?)or linux?
Tera term should be run in Windows only.

Understand, I will study how this spy monitor works to find the cause,
In addition, my platform is a modem built on Linux, and I use a laptop to connect to it through Console to enter commands