EM9191 FDT2.exe multiple firmware and PRI image loading

I’m trying to flash multiple firmware images (and PRI) onto an EM9191 module with fdt2.exe but it will only flash them on firmware slot “1”, and “2” If I flash one image at a time, it keeps overwriting the last one, thus not allowing me to swap PRI with !IMPREF as I’m guessing they are getting orphaned.

TLDR: What is the syntax to flash multiple images and PRI and have it use all firmware image slots, NOT just slot “1” so that I can swap PRI images at will?

Command I’m using:

fdt2.exe -d g5k -resettimeout 3 -timeout 15 -f SWIX55C_03.04.03.00-001.cwe SWIX55C_01.07.23.00-001.cwe SWIX55C_01.07.13.00-005.cwe SWIX55C_03.04.03.00-001_GENERIC_030.012_000.nvu SWIX55C_01.07.23.00-001_VERIZON_012.019_000.nvu SWIX55C_01.07.13.00_ATT_012.007_002.nvu SWIX55C_01.07.13.00_TMO_001.005_003.nvu -mi -impref SWIX55C_03.04.03.00-001.cwe SWIX55C_03.04.03.00-001_GENERIC_030.012_000.nvu -force -log logs

Command outcome:

Prior to running commands over and over again, lol:

Here you see the multiple PRI exist after running the above command, but there are only two FW image slots being populated with an image. It’s skipping, or overwriting, SWIX55C_01.07.23.00-001.cwe. This making the Verizon PRI an orphan.
image

Maybe My fdt2.exe command syntax is off somewhere?

halp!

Honestly I’m not sure how I got the image #2 to stick. I tried duplicating on a fresh module and it will not flash to fw image slot #2 or #3. It just writes the first image and the others go into the ether and the PRIs get put in and orphaned.

image

Edit: I updated to the images just posted a few days ago for this one.

how about without the “-force” parameter?

Tried with and without. Same outcome.

I’ve messed with it more on a fresh modem and now I have NO idea how I got a second firmware slot to populate on the first modem. I can only get it to repeatedly overwrite the first slot.

No other modem I have does this, except these 5G modems.