EM7590 not visible in Win11 on Panasonic Toughbook FZ-G2 (mk1)

Hello everyone,

I have replaced the original EM7455 in my Toughbook FZ-G2 mk1 with an EM7590 to get more LTE bands and a bit more of connection speed.

The EM7455 needs a Wireless WAN ID of 29 to work properly.

But for the EM7590 I’m unable to get this to work.
Win11 doesn’t see the hardware and therefore no driver will install or help.
I tried every WAN ID from 01 to 30, no luck.

Panasonic Support just says “this is not original hardware, so we do not support this” so no help from them.

Has someone a hint about the correct Wireless WAN ID for the EM7590 to work in the FZ-G2?
Any help would be appreciated.

Thank you :slight_smile:

did you install the USB driver?


What did you see in device manager?

Hi @jyijyi,

thanks for your help. I tried the driver first, but it didn’t help.

Windows doesn’t see the hardware, because BIOS seems to disable the WAN Card without the correct Wireless WAN ID.
If the hardware is visible to the operating system, I’ll get a “unknown device” in device manager, but nothing shows up at all.

So I’m stuck with a none-working card. This “Wireless WAN ID” seems to be a Panasonic specific thing.

not sure what is the meaning of “wireless WAN ID”
Is this related to the USB PID?

to verify if your module is working fine, you can install linux virtual machine and see if it can enumerate MBIM and AT command port in linux PC

I’m not familiar with installing Linux, sorry.

I inserted SIM card in the SIM slot and after reboot I got a message from my service provider “hey your SIM ist now active in an EM7590”, so I belive the WAN card itself is working correctly (even got signal and connected to provider).

Edit: No, W. WAN ID has nothing to do with the USB PID. This ID has to be changed in BIOS.
And no, card still missing in device manager, no wan connection showing up.

the message from service provider does not mean the M.2 adaptor is working fine with the PC hardware, unless checking with another OS.

Ok, I’ve installed a Linux VM. I hope Hyper-V with Ubuntu 22.04 will do, was the first guide for a install and now it’s updating some apps and will be ready.

Now, sending commands to the EM7590 card is another thing, not sure what to do :slight_smile:

i remember only VMWare can switch the USB to virtual machine

Not sure if Hyper-V can do so

Hm. So installing Hyper-V and Ubuntu was for nothing? Didn’t know this would only work with VMWare, I use Hyper-V once in a while so it seemed the easiest option. :sob:

i am not sure, you can double check if Hyper-V can work

I installed hardinfo app, and under USB and PCI no device is displayed at all.

then maybe you can try VMware

Ok, got VMWare Workstation Player 17 running.
Installed Ubuntu 20.04 with upgrade over 23.x to the latest 24.04 LST.

The EM7455 can be connected to the VM, Ubuntu sees it, Mobile Wireless running fine.

I’ll change back to the EM7590 the next days, will report here what happens next.

I changed back to the EM7590 yesterday.

No device in Windows Device Manager and no USB device in the VM-Controller menu to hand over to the Ubuntu VM.

Meanwhile I tried the EM7590 in a non-Panasonic laptop, and it worked from start, without mingling into BIOS settings or even need to manually install a driver (got delivered from Windows Update system).

So I believe it really has to do only with this strange Panasonic “Wireless WAN ID”, wich has to be set to the correct value, and if this doen’t match the operating system will never get to knwo about the WWAN card.

Finally, I will stick to the EM7455, it does the job, maybe with a little bit less speed than with other cards, but as long as this is the only option, may it be as it is.

Thank you @jyijyi for your help, I got to learn a bit more about Linux and VMs, so it wasn’t for nothing :slight_smile:

If someone ever find the correct ID for the EM7590 to use in a Panasonic laptop/tablet, just let me know.