EM7455 - Two Network Adapters on Windows 10

On Windows 10, the EM7455 module with the latest firmware and drivers presents two Network Adapters to the OS. Is this a bug?

What is the return of
At!entercnd=“A710”
at!usbcomp?

image

Hi Jyi Yip,

image001.png

Wrong quotes. Use

at!entercnd="A710"
at!usbcomp?

Not that it matters much. The point is that it is possible to configure the EM7455 as"two network adapters" in the form of two RMNET functions. But I don’t think that’s a common configuration with newer (>=8) WIndows versions. I believe the Windows driver is supposed to force the modem to MBIM, which is only availabe as “one” USB function. It supports 8 multiplexed IP/APN sessions though, so you could very well define it as multiple network adapters. I have no idea how WIndows represents these things…

Well spotted with the quotation marks. That was a consequence of copy/pasting from this post.

image

This is how the adapters are presented in Windows:

adapters

This results in two interfaces appearing in the networ taskbar GUI, making things a little confusing:

As this modem will be embedded in a medical device, it will compicate the embedded code trying to determine which adapter is in use or which to turn on/off. It’s not a huge problem but the EM7565 we initially tested only presents one adapter making control/status easier to code for.

Another issue seems to be that the device names change when the modem is unplugged/plugged. So the modem port is COM5 to start with then changes to COM8 when unplugged/plugged. The network adapter instance change name too. Again, this complicates the embedded code and the EM7565 didn’t have this problem.

adapters

This looks basically fine to me. You can disable the addtional RMNET function if it is a problem:

at!entercnd="A710"
at!usbcomp=1,1,10d
at!reset

Hi Bjørn,

Yes, that did the trick. Many thanks.

Most importantly, this change results in the modem COM port number and network interface name staying the same across power-cycles.

Q1: Is there an AT command reference manual for this modem I could download?

Q2: What is the command to get back to the default/factory setting

Best regards

Tim Clacy

You’ll find the AT command reference here: https://source.sierrawireless.com/devices/em-series/em7455/

I don’t know what the factory setting is, but you can go back to your previous settings with

at!usbcomp=1,1,50d

Bjørn,

The bitmask you suggested doesn’t seem to correlate with the bitmask defined in the AT command reference manual as regards the mask enabling MBIM (why isn’t the mask 0x000100d instead of 0x000010d to enable MBIM)?

Valid values (available interfaces are device-dependent):

0x00000001—DIAG

0x00000004—NMEA

0x00000008—MODEM

0x00000100—RMNET0

0x00000400—RMNET1

0x00001000—MBIM

0x00010000—AUDIO

Regards

Tim

The mask I suggested disabled RMNET1 and kept RMNET0 enabled.

100d is the correct mask if you want to enable MBIM instead of RMNET.

Hi Bjørn,

It seems that the EM7455 doesn’t support MBIM. After I entered the following, no devices appear in Device Manager (no modem, no NMEA, no DM and no WWAM).

image001.png

Do you have any suggestion on how I can get this module back into a state where I can talk to it through the AT port?

Regards

Tim

It most certainly does.

Ouch. That’s unexpected. And there isn’t any unknown USB devices showing up instead, either?

I’m afraid I can’t help revive that in Windows. I am pretty sure it’s possible, but I just don’t know enough about the platform to say how. I can try to give some generic platform independent hints: The assumption is that the modem has changed into something which isn’t recognized by any installed driver. First step is to figure out what that is (device ids and usb interfaces/functions). Then install and/or bind whatever drivers are necessary to access the modem functions in that mode. At least the AT command function if that is available. Then optionally switch it back to whatever mode worked before.

A bit too late to say this, I guess. But in case anyone else stumbles across this thread: The reason I suggested keeping RMNET0 instead of replacing it with MBIM was that you obviously had an installation which was working with RMNET. The principle of making as few changes as possible to any working config…

Bjørn,

It’s alive… and the MBIM mode has taken too:

image001.jpg

It seems that there is an issue with these modules after changing configuration. Resetting the module using:

at!reset

Is not sufficient. In fact, it seems to cause Windows device manager to hang. I ended up unplugging the module, power-cycling the laptop, then reconnecting the module. Now it’s working with the correct interface selection.

Regards

Tim

Hi, it’s alive again [see post to Bjorn]. it seems the problem is that a connect/disconnect is required after re-configuration?