EM7455 loosing GPS fix after some hours of operation

Hello,
we are using the EM7455 in OnBoardUnits for vehicles (mostly railway) with LTE and GPS/GNSS capabilities.
On some of theses boxes GPS /GNSS fix reproducible seems to get lost after some hours of operation.
(so GPS is working in general)
We are using the NMEA-serial interface (/dev/ttyUSB1) in Linux environment and the AT-Command
interface (ttyUSB2) for controlling (and getting information about mobile network).

Whenever this problem happens I still get NMEA-data from EM7455 but with “no location”
(p.e. ‘GPRMC’ with “Void” marking). If I reset the device in this situation GPS is almost instantly again
available. (so antenna, power supply or simple vehicle “parking situation” could be excluded
from causing this.)

Is there a proper way to get this device to keep alive the GNSS receiver? Or is there some other
recommended way to “reactivate” GPS (without reset)?
Any hints are welcome - thanks.

Sebastian

Are yoh using AT!gpstrack to start the gps fix?

Hi,
no. I set the following:
AT!GPSNMEASENTENCE=030B
AT+WANT=1
AT!GNSSCONFIG=1,1,0,2
AT!GPSAUTOSTART=1,1,180,200,1

The device is configured with
AT!USBCOMP=1,1,100D
so I have an MBIM-Channel for data, AT-Command serial line and NMEA. After opening the
NMEA serial interface I send “$GPS_START” and all runs well (up to some hours after startup).
The time when GPS fix is lost is not always the same… In some cases devices are running several weeks
without problems, in other cases it “quits” after some hours…

I saw the “!GPSTRACK” command in documentation. But I since I don’t want to collect
GPS information with “!GPSLOC” I didn’t use it.

Sebastian

have you tried at!GPSEND and AT!GPSTRACK to reactivate the GPS session?

The problem with “!GPSTRACK” is that this is always a time limited operation. or?
I tried this:

  • Opening NMEA-Port (ttyUSB1)
    → Device sends subsequent NMEA data (with location data)
  • Calling “AT!GPSTRACK=1,15,10,10,1” (ttyUSB2)
    → “ERROR
  • Calling “AT!GPSEND
    → “OK” and NMEA-data immediately stops on ttyUSB1
  • Calling “AT!GPSTRACK=1,15,10,10,1
    → “OK” and NMEA-data appears for 10 seconds on ttyUSB1
    After 10 secs NMEA stops (completely).

I’m not sure but this not the same behavior i’ve seen in “field”. There
the NMEA-stream does not stop - I reports empty data (just like
the situation when antenna is covered or broken) - but a restart of the
EM74455 brings back GPS - so it must be something internal to EM7455.

I need a permanent NMEA stream. With “!GPSTRACK” it is only time limited and
stops without notice. Is there something that just restarts the internal GPS receiver?
I tried “!GPSCOLDSTART” but this command is probably not supported in current firmware.(?)

I saw for at!gpstrack

(Number of position fixes requested)
• Valid range: 1–1000 (1000—Take a continuous series of position fixes)

Also Before using at!gpscoldstart, you need to end all active GNSS sessions using
AT!GPSEND=0,255.

ha - found the problem with “!GPSCOLDSTART”…
this command is password protected - after unlocking, this works (as expected).
But, if possible I would like to avoid this.

If no other solution is possible (hard to believe that no one had this problem bevor?)
I will give a chance to the combination of “!GPSTRACK” and “!GPSEND”.